Problem with, undefined symbol ucal_inDaylightTime_67

Hello everybody!

After updating my Manjaro installation, I’m unable to run several programs due to the following error:

$ okular
okular: symbol lookup error: /usr/lib/ undefined symbol: ucal_inDaylightTime_67
$ dolphin
dolphin: symbol lookup error: /usr/lib/ undefined symbol: ucal_inDaylightTime_67

I wasn’t able to find any useful solution for this, yet. Re-installing or re-downloading the qt5-base didn’t solve the problem.

Can you please assist or give me a hint? Thanks in advance!


Could you provide a full update log?

Did you install packages from aur?

Maybe try to downgrade this package and see if it works then?

downgrade qt5-base

Redownload old database and upgrade again?

pacman-mirrors -c Germany && pacman -Syyu

(chose another country if you need to)

Hello megavolt,

thanks for the quick answer. I’ve tried to downgrade and to redownload the old DB and upgrade again, but both solutions didn’t help.

How can I do this?

I hope this is correct:

$ pacman -Qm
cndrvcups-common-lb 4.10-1
cndrvcups-lb 3.70-1
emojione-picker-git 0.1.r37.gcb5f504-4
fontforge-git 1:20190801.r287.g47838fc54-1
gamin 0.1.10-9
gksu-polkit 0.0.3-2
google-chrome 86.0.4240.75-1
gtk-xfce-engine 2.10.1-2
lcms 1.19-7
libnm-gtk 1.8.19dev+21+geebf7f95-1
libunicodenames 1.2.2-1
libxkbui 1.0.2-6
mhwd-catalyst 1:15.201.1151-2
mhwd-nvidia-304xx 1:304.137-1
nodejs-lts-carbon 8.16.2-2
ookla-speedtest-bin 1.0.0-3
openoffice 4.1.7-1
pycharm-professional 2020.2.2-1
python-sip-pyqt5 4.19.19-3
python2-cairocffi 0.9.0-1
python2-cairosvg 1.0.22-1
python2-cssselect2 0.2.1-2
python2-pdfrw 0.4-3
python2-pyphen 0.9.4-1
python2-pytoml 0.1.21-3
python2-tinycss2 0.6.1-2
python2-weasyprint 0.42.2-1
python2-xcffib 0.9.0-1
sendmail 8.16.1-1
spotify 1:
ttf-ms-fonts 2.0-12
u2f-udev-rules-git r213.82583f6-1
viur-control 0.31.0-1
xdg-su 1.2.3-2
xf86-input-keyboard 1.9.0-3
xf86-input-mouse 1.9.3-1
xorg-font-utils 7.6-6
xorg-fonts-alias 1.0.3-3

I’ve also recognized that when I want to run libreoffice, I’m getting another error:

$ libreoffice --calc
/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/ undefined symbol: _ZNK6icu_678Calendar17getFirstDayOfWeekER10UErrorCode

Both errors have something to do with calendar functions, might this be the reason for the problem?

Please check if the /usr/lib/ is symbolic linked to /usr/lib64 …

ls -la /usr

and the pacman.log is here:

cat /var/log/pacman.log

for listing AUR packages, that would be better:

pamac list -i | grep AUR
1 Like
$ ls -la /usr 
insgesamt 460
drwxr-xr-x  11 root root   4096  7. Okt 16:11 .
drwxr-xr-x  17 root root   4096  7. Okt 11:39 ..
drwxr-xr-x   6 root root 126976  7. Okt 16:11 bin
drwxr-xr-x   2 root root   4096 28. Nov 2018  etc
drwxr-xr-x 526 root root  36864  7. Okt 13:22 include
drwxr-xr-x 220 root root 196608  7. Okt 15:46 lib
drwxr-xr-x  29 root root  36864  7. Okt 11:39 lib32
lrwxrwxrwx   1 root root      3 26. Sep 14:06 lib64 -> lib
drwxr-xr-x  11 root root   4096  1. Jul 2018  local
drwxr-xr-x   3 root root   4096 21. Aug 2019  man
lrwxrwxrwx   1 root root      3 26. Sep 14:06 sbin -> bin
drwxr-xr-x 285 root root  12288  7. Okt 13:19 share
drwxr-xr-x   2 root root   4096 27. Apr 2018  src


The output is empty.

Ok next questions :smiley: :

Is there something in the ignorelist?

cat /etc/pacman.conf | grep Ignore

Did you really change your mirror?

sudo pacman-mirror -c all && sudo pacman-mirror -f 10 && sudo pacman -Syy && sudo pacman -Syu

This guy here has the same problem. There was an outdated mirror and he has a ignore list: [SOLVED] Problems with last update

First of all sorry for long time to respond. I’m use this computer not every day, but the problem is still exist.


$ cat /etc/pacman.conf | grep Ignore
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

I think you mean pacman-mirrors. There wasn’t any package updated.