Problem with headphones audio

Hello, im new in linux and i have been running into a lot of problems with audio and i still cannot find a solution to my problem. I have my headphones plugged but i cant hear anything and the microphone is not working neither.

Here is my inxi -SMA output:

Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.5
Distro: Manjaro Linux
Machine: Type: Desktop Mobo: N/A model: X79 serial: UEFI: American Megatrends v: 4.6.5
date: 04/30/2019
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel
Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel
Sound Server: ALSA v: k5.9.16-1-MANJARO

PS: Sorry for my english, its not my matern language

In the terminal, type alsamixer, and check if anything is muted. If you see something muted, unmute it.

Sorry for the late response. I already checked alsamixer and everything is unmuted.

Here is a bit more of information


Kernel 5.9.16-1-MANJARO is End Of Life and you should install Kernel v5.10

dmesg section is showing you have an out of date modprobe option

!!ALSA/HDA dmesg

[    3.675809] snd_hda_intel 0000:00:1b.0: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
!!Modprobe options (Sound related)
snd_hda_intel: model=pch position_fix=1
snd_hda_intel: dmic_detect=0

The first modprobe option is not helping either
There is no model option pch listed in kernel documentation
and the PCH onboard audio devices is shown as device 0 and ignoring the position_fix=1

I suggest you find the file(s) where you created these modprobe options

grep -n snd /etc/modprobe.d/*.conf

Remove both of them and install package sof-firmware

Then reboot system and see if sound is working OK

The new modprobe option options snd-intel-dspcfg dsp_driver=1 might not be needed if the internal microphone array is supported by Sound Open Firmware drivers

Hello, thanks for the reply. I removed both modprobe options, updated the kernel and installed sof-firmware. Still no luck :confused:

Please post reponse to

sudo --upload

It looks like snd_hda_intel: dmic_detect=0 is still in modprobe options but grep -n snd /etc/modprobe.d/*.conf outputs nothing

If you did not add this option in folder /etc/modprobe.d/ , you might have added it to GRUB boot options

I suggest you check if this option is listed in the boot paramaters

inxi -Sa

If that is showing the option to disable the dmic, you will probably have added it to system file /etc/default/grub

Edit this file manually to remove the option
and update GRUB to save the changes

Alright, i removed the option from GRUB boot options but i forgot to update it. This is the updated sudo link:

ALSA is still not able to identify the Manufacturer or motherboard model
There is not even an ID code within the audio codec - Subsystem Id: 0x00000000
I suggest you check online support for your motherboard to see if there is a BIOS update for firmware v4.6.5

There is still an error in DMESG

snd_hda_codec_realtek hdaudioC0D2: ignore pin 0x1b with mismatching assoc# 0x2 vs 0x1

and only 4 line_out connections detected in ALSA

snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    3.593671] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.593674] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)

Data in !!HDA-Intel Codec information shows that the ignored pin 0x1b is the connection for front headphone jack

Node 0x1b [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000373e: IN OUT HP Detect Trigger
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x02014c20: [Jack] Line Out at Ext Front
    Conn = 1/8, Color = Green
    DefAssociation = 0x2, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 5
     0x0c* 0x0d 0x0e 0x0f 0x26

I suggest you install package alsa-tools
and run this to try to retask the jack to a working state

sudo hdajackretask

Find the pin connection

Green Line Out, Front Side
Pin ID: 0x1b

Enable the Override and set it to ‘Headphone’ and click Apply boot override

reboot system and check if Headphone jack is working

Unfortunately that didnt work, here is an updated sudo

Im using a chinese motherboard so i guess thats the problem. The only way i can get sound is by connecting the headphones into my monitor.

The jack retask worked for the headphone jack
snd_hda_codec_realtek hdaudioC0D2: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)

But the Master volume control has been muted and turned down

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] [-64.00dB] [off]

Use this command to unmute and reset level to 100%

amixer -c0 sset Master 64 unmute

Thank you so much, this worked!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.