Problem with booting into Manjaro 18.02 KDE

#1

Hello people. :slight_smile: So nice to be a part of the Linux community. However, I am here because of a small problem that I am having currently. I am having problems booting into Manjaro. When I turn on my PC, it boots, but it shows a black screen. However, when I hit Alt-F1 and then ESC, it boots into the GUI. And then it works perfectly fine. I have already tried changing SDDM with SDDM-classic, but it didn’t help. startx doesn’t give any errors when I run it from the tty. Any advice and solution would be really helpful. Thx. :slight_smile:

0 Likes

Long boot time 18.0.4 Cinnamon (SSD)
#2

Maybe it’s a wayland problem.

1 Like

#3

Test if pressing random keys has the same effect, because if so, then might be an entropy thing.
From terminal
sudo pacman -S haveged
sudo systemctl enable haveged --now

To be honest, that will make no positive difference, and better use the SDDM 0.18 that comes by default, so switch back to that.
Reboot.

^This!
Make sure you don’t boot in plasma-wayland-session as default and with autologin enabled, it has the tendency to mess things up.

1 Like

#4

Thanks man, it was an entropy thing, hitting random keys had the same effect, I have enabled haveged, and now it is perfect. Thanks! :smiley:

0 Likes

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes