problem with audio

after installing the latest stable version of manjaro with plasma i'am facing this trouble:
after restart/booting my system the audiodevice doesn't work properly. after googeling i realised that i have to open the terminal and by using the "pulseaudio -k" command i'am able to start the sound daemon to work properly. this is annoying but i have no idea how to solve this issue. can anyone help?

You might want to give this post a read. Without good information, nobody can help you.

1 Like
System:    Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=da2cef41-a369-4bb5-af19-c6e84ec90e97 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Predator PH317-52 v: V1.19 serial: <filter> 
           Mobo: CFL model: Sienna_CFS v: V1.19 serial: <filter> UEFI: Insyde v: 1.19 date: 07/13/2018 
Battery:   ID-1: BAT1 charge: 46.8 Wh condition: 46.8/48.9 Wh (96%) volts: 16.3/15.2 model: LG PABAS0241231 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: B4 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 879 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 902 8: 900 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Acer Incorporated ALI driver: nvidia v: 435.21 
           bus ID: 01:00.0 chip ID: 10de:1c8c 
           Display: x11 server: X.Org 1.20.5 driver: modesetting,nvidia compositor: kwin_x11 resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fb9 
           Sound Server: ALSA v: k5.3.6-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 3000 bus ID: 07:00.1 chip ID: 10ec:8168 
           IF: enp7s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 bus ID: 08:00.0 chip ID: 8086:24fd 
           IF: wlp8s0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 12.43 GiB (2.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 512GB size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXP7 scheme: GPT 
Partition: ID-1: / raw size: 232.30 GiB size: 227.65 GiB (98.00%) used: 8.72 GiB (3.8%) fs: ext4 dev: /dev/nvme0n1p1 
           ID-2: /home raw size: 244.14 GiB size: 239.31 GiB (98.02%) used: 3.71 GiB (1.6%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 221 Uptime: 2h 27m Memory: 31.21 GiB used: 1.94 GiB (6.2%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36 

i can solve this by adding the command "pulseaudio -k" to the autostart. the audio device is then working without problem. my question is why i have to do this. i hadn't this strange behaviour before and i have no idea what causes this behaviour.

not a good idea to use pulseaudio -k
it does restart Pulseaudio but will be missing some modules
including one needed specifically for KDE: module-device-manager

better to use:
systemctl --user restart pulseaudio

for a fresh install would not need to clear old Pulseaudio settings database files in home folder

suggest installing pavucontrol-qt
check mute buttons in 'Playback' and 'Output Devices'
and in 'Configuration' change devices profile to 'Off' then back to usual setting

pavucontrol sometimes corrects audio just by making these changes
i think it corrects the ~/.config/pulse/ database files in a way that KDE controls can't manage initially

2 Likes

Forum kindly sponsored by