Problem while updating manjaro

Hello, I am getting problem while updating manjaro. It is showing failed retrieving file core.db from : SSL certificate problem: certificate has expired. Please help me out ASAP. Also I can’t open terminal, and can’t update from tty mode also

Welcome to the forum! :slight_smile:

Boot up from the installation medium ─ the USB stick or the CD/DVD that you installed from ─ in live mode and open up a terminal window. In this terminal window, issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a

When prompted, enter the number of the GNU/Linux installation that corresponds to your Manjaro system. Next, issue the following command… :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu

Let it finish, and then when the command prompt returns, simply type… :arrow_down:


… or hit Ctrl+D. It should now be safe to reboot your system, and all should be well.


Unfortunately I didn’t have the installation media and I can’t create any at the moment as I can’t go out from home because of lockdown. I only have one laptop and a mobile right now with me. I have usb stick though but can’t make a bootable drive as terminal is not opening, further to add little bit more in my problems, I can’t even install a software from packages. this mirror doesn’t work at night, so switch to other mirror

I have changed the mirrors and system get updated. But terminal still not working. How to solve terminal problem?

try this

You could also just try to run that command from TTY

If you can boot your system, press
or use any other Fx key between 2 and 6

log in and run the two commands suggested
or run them separately, like so:

pacman-mirrors -f 5
pacman -Syyu

to get back to the graphical interface

The OP indicated that they cannot get to a tty, any more than that they can open a terminal window. That’s why I advised using the install medium.

Surely you can order one online and have it delivered to you?

Oh, yes, he did - I read that but somehow discarded it because it made no sense to me that he can boot, get to UI - but cannot get a TTY.
But yes - he did say that.

1 Like

I just made a bootable usb by installing another terminal and going to install solus. Manjaro was always a pain in ass after some duration of time. It always lend me in a problem when I need my laptop most.

I can get to tty, but wasn’t able to update either from there.

That’s too bad.
Good luck with Solus, where the variety of software to choose from is much more limited.
But that may not matter to you - now or ever.

Then by what strange kind of sorcery is it that in the now two years of my using Manjaro as my daily driver, I seem to have never run into any of these earth-shattering problems that all of the newbies are experiencing (and blaming Manjaro for)?

So, which is it going to be, then? If you’re going to ditch Manjaro, then we’re wasting our time on this thread.

… it’s strange that he/she can install a new terminal, but can’t refresh the mirrors and then subsequently update …
… whatever

1 Like

Then what should I do? I don’t know why but I always find myself in some problems when using manjaro. Even though I love manjaro the most, but I want spend some time with other distro as well to know about what they have to offer

I already done refreshing of mirrors and selecting from other country. And only after that, system get updated and also I was able to install another terminal.

I have been using manjaro for 2 years as well and it always cost me a new problem everytime. Sometimes with network manager after a random update, sometimes some software not working properly. My machine is 11 years old, maybe that’s why this is happening or whatever I don’t know.

It’s completely your choice.
You can see in my profile that I don’t run Manjaro
(I do - but just in a virtual machine for testing and advising purposes …)
as I had a similar experience.
… always something …, well, not always, but frequently enough to be annoying
especially if it is not only my own system I have to keep current and up and running

I run Arch, installed through the ArchLabs installer (just because it’s easier to install).
I never grew happy with Manjaro.
I came from Arch - and went back to it.

Thats exactly what I want to say, not always but frequently enough to be annoying. Even though Manjaro is very good, but only if it is not annoying at times when you need it the most. It looses the morales of using Linux which was meant to be problem free and smooth experience. I have used Arch Linux one time, had a good experience with it, not like Manjaro which keep annoying like a kid in supermarket.

Then I suggest to have a look at EndeavourOS or the ArchLabs installer.
Both install a rather clean Arch, but already slightly customized.
Read their web pages to know what to expect - or just try, if you have the time.