Problem trying to run command from terminal into guake with "---execute-command="

Hello, recently i tried to make a script and i want to execute him into guake but when i tried the option “—execute-command=” i had an error:

Traceback (most recent call last):
  File "/usr/bin/guake", line 33, in <module>
    sys.exit(load_entry_point('guake==3.8.6.dev20', 'console_scripts', 'guake')())
  File "/usr/lib/python3.10/site-packages/guake/", line 634, in exec_main
    if not main():
  File "/usr/lib/python3.10/site-packages/guake/", line 553, in main
  File "/usr/lib/python3.10/site-packages/dbus/", line 72, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python3.10/site-packages/dbus/", line 141, in __call__
    return self._connection.call_blocking(self._named_service,
  File "/usr/lib/python3.10/site-packages/dbus/", line 652, in call_blocking
    reply_message = self.send_message_with_reply_and_block(
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/dbus/", line 662, in _message_cb
    (candidate_method, parent_method) = _method_lookup(self, method_name, interface_name)
  File "/usr/lib/python3.10/site-packages/dbus/", line 254, in _method_lookup
    raise UnknownMethodException('%s is not a valid method' % method_name)
dbus.exceptions.UnknownMethodException: org.freedesktop.DBus.Error.UnknownMethod: Unknown method: execute_command is not a valid method

My guake --version show me:

Guake Terminal: 3.8.6.dev20
VTE: 0.68.0
VTE runtime: 0.68.0
Gtk: 3.24.33

I’m not really able to resolve this problem, i tried to google it but i wan’t able to understand how to resolv it.

If somebody has a solution for me it would be good, i tried on ubuntu with my vm and it worked…

I can duplicate this issue. Looks like the --execute-command option was removed recently due to security issues. There is a new PR which fixes this but has not been merged yet:

Both ubuntu and arch are running the same version so don’t why that’s happening. You can switch to any other drop down terminal…possibly yakuake.

Thanks, i see yakuake a possibility to send a command to it but there is not a lot of option for the tab ect so i’ll wait an update i guess.