Problem to have High Quality Audio on Manjaro

I’m trying to have high audio quality on linux manjaro.
I followed some guides that advise me to edit the /etc/pulse/daemon.conf file
This is the configuration file of pulseaudio
In particular these lines how follow:

; default-sample-format = float32le
; default-sample-rate = 192000
; alternate-sample-rate = 48000

But it has no real effect on pulse audio settings.
Giving the command pacmd list-sinks i can see how the sample is ever that for my integrated audio card

sample spec: s16le ch 2 44100 Hz

Why?
There is some other method to have high quality audio on Manjaro?
Thank you very much for every help

the configurations in /etc/pulse/daemon.conf are commented out by a semicolon ; at the start of each line. delete the semicolon to change settings

manpage pulse-daemon.conf
The configuration file is a simple collection of variable declarations. If the configuration file parser encounters either ; or # it ignores the rest of the line until its end.

But a custom configuration can be created in user home folder and system configuration can be retained with default settings

To create a custom profile in user home folder ~/.config/pulse/daemon.conf

tee ~/.config/pulse/daemon.conf <<< 'default-sample-format = float32le
default-sample-rate = 192000
alternate-sample-rate = 48000'

Restart PulseAudio to load new settings

systemctl --user restart pulseaudio

To check daemon configuration

pulseaudio --dump-conf

Uncomment the lines you modified. The default settings are commented out with a ; :wink:

default-sample-format = float32le
default-sample-rate = 192000
alternate-sample-rate = 48000

Thank you much, has worked :smiley:
I’m very noob yet on linux and this shows
Thanks Again :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.