Problem running nixnote2 after update

Unfortunately, I have a completely different problem that nobody else has had. I would post it in another forum, but it has actually only occurred directly after this update. My nixnote2 never had any problems and now when I try to start it I get this message in the terminal, when i enter nixnote2:

nixnote2: error while loading shared libraries: cannot open shared object file: No such file or directory

I never had this before. I could reinstall nixnote2, but i hope somebody knows a quick solution maybe to establish connection to the needed libraries.

nixnote2 is an AUR package. The library it is needing got updated to version 74. You probably have to reinstall/rebuild nixnote2, so it links to the new version of the library. There is no other solution.


You are actually supposed to rebuild all your aur stuff on every update.
In that particular case nixnote2 depend on boost-libs which depends on icu which got updated to ver 74.
I had the same “problem” with fsearch.


OK, so first of all thanks for your support. It actually worked differently for me. I had forgotten to update my AUR packages after the last system update. I didn’t give Pamac access to the AUR by default, so I always have to update it separately afterwards with yay.
Actually, I only typed


in. The update actually took a strangely long time today. It took almost 3 hours and almost the whole time the qt5-webkit package was being built. But when it was finished, nixnote worked without any further intervention.

1 Like

Maybe you should try the nixnote2-appimage AUR package. That way you don’t need to recompile the package. It’s a binary package.

I didn’t have to recompile nixnote2. I just needed to complete my system-update via yay, which was updating something about JavaScript (qt5-webkit). i even couldn’t find any intervention in the nixnote packages, although it took 3 hours.
Btw i used the nixnote2-git-version, because the normal nixnote2-package didn’t work, so was actually happy to find the right version and am still satisfied.
Thanks anyway for your participation and the tip.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.