Problem on virtualbox with guest kernels higher than kernel 4.4

virtualbox

#1

I have manjaro-xfce on my main (host) machine and the same on virtualbox, but guest kernels higher than guest kernel 4.4 (4.5, 4.6, 4.7) doesn’t work, although I have no problems with host kernels (even with 4.7rc).
I get a black screen with a blinking cursor.
I was waiting the new virtualbox 5.0.22, now I’m with it, but the problem still exists.
Is there something wrong with those kernels, or am I the only one with this problem?


I always can't start my os in virtual box after update kernel
Manjaro Deepin update (testing branch)
#2

Try to search virtualbox documentation to find out what kernels are supported. I once had similar issue with OpenSUSE Tumbleweed which had the latest kernel. The solution was to uninstall guest additions, though video qulity suffered.


#3

Unfortunately, unistalling guest additions didn’t help.
I tried dkms (dkms-manjaro, dkms-host and dkms-guest) but the problem still exists.


#4

If I remember correctly, I uninstalled virtualbox-guest-utils to solve that issue. If that did not help, your problem might be not the same.


#5

This virtualbox changelog https://www.virtualbox.org/wiki/Changelog#v22 suggests that 5.22 version should work with 4.5, 4.6 and 4.7 kernels.


#6

I unistalled virtualbox-guest-utils aswell but nothing changed.

I have already 5.22 version as i mentioned before (because I’m on unstable branch) and I still have the problem.

Thank you kainonergon!


#7

These are the known errors currently: Issues with Ellada. Please check and uninstall plymouth if you’re using kernels higher than 4.4 in your machine.


Virtualbox guest kernel 4.7.0 - Oops: 0010 [#1] PREEMPT SMP, BUG: unable to handle kernel NULL pointer dereference
#8

Thanks a lot philm, problem resolved! :slight_smile:


#9

@philm unistalling and installing again plymouth, 4.6 guest kernel worked normally without issues this time!
Now I’m with 4.6 guest kernel and plymouth! :slight_smile:


#10

Did not work for me… only Kernel 4.4 gives me a GUI, the other ends in X.Org errors.

The X.Org log in /var/log/ gives me alot(!) warnings and these errors:

  • Failed to load module “vboxmouse” (module does not exist, 0)

and later:

  • Fatal server error: AddScreen/ScreenInit faild for driver 0

Any help would be appreciated
Thanks in advance
LAZA


#11

Higher than guest kernel 4.4 (4.5, 4.6, 4.7) doesn’t work nor to me now.


#12

Thanks for the reply.
We hope for VirtualBox 5.1 - got today the guest modules in unstable.


#13

I’m on unstable branch, I have already VirtualBox 5.1 but unfortunately doesn’t work. :disappointed_relieved:


#14

What about VB 5.1.2?

I tried but does not work (for me)…


#15

Do you mean ? No start ?


#16

Unfortunately also doesn’t work for me, but oberon try to fix it.


#17

You have two options. First, remove the plymouth, second you can follow the workaround:

Edit /etc/default/grub and append iomem=relaxed to the GRUB_CMDLINE_LINUX_DEFAULT variable, so it would look similar like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet iomem=relaxed"

Then run:

sudo update-grub

Bernhard found the kernel config, which creates that mess, however you can use the kernel parameter, as this is only related to VirtualBox and doesn’t affect systems installed on real hardware.


#18

Thanks a lot philm!
Problem fixed with grub kernel parameter for guest 4.6 but I get “floppy0 no floppy controllers found” with guest 4.7 and doesn’t boot.


#19

Tried this with an RC from 4.7 and did not work for me…

Maybe i have a little spare time on the weekend to try the second solution - but prefer a “official” one from your guys with the big plan and knowledge! :smiley:


#20

Starts but no GUI, some error with X.Org
https://forum.manjaro.org/t/problem-on-virtualbox-with-guest-kernels-higher-than-kernel-4-4/4415/10?u=laza