Problem beim Start von Civilizaton V mit Steam (andere OpenGL Version benötigt?)

gnome

#1

Hallo zusammen,

ich spiele gern, da Steam nun wirklich gut unter Linux funktionert gab es bei mir einen Tausch,
Linux ist nun Host und Windows Guest (VM) ;-).

Zu meinem Problem, Civilization V startet nicht mehr, es erscheint kurz ein schwarzes Fenster danach passiert nichts mehr. Bei meiner recherche bin ich auf eine Aussage gestoßen, welche aussagt, das für dieses Spiel OpenGL 3.1 installiert sein soll. Mit höheren Versionen würde es nicht mehr funktionieren. Kann dies jemand bestätigen?

Jetzt zur eigentlichen Frage, wenn dem so ist, dass ich OpenGL 3.1 benötige, wie bewerkstellige ich dies und ist es überhaupt ratsam. Hier mal meine OpenGL Version:

[ktt73@KTTs-Kiste ~]$ glxinfo | grep 'version'
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 4.6.0 NVIDIA 415.25
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL version string: 4.6.0 NVIDIA 415.25
OpenGL shading language version string: 4.60 NVIDIA
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 415.25
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
GL_EXT_shader_implicit_conversions, GL_EXT_shader_integer_mix, 

Hier auch die Fehlermeldung die Steam beim Start auspuckt:

Summary
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to ProcessingInstallScript with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to SynchronizingCloud with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to ProcessingShaderCache with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to CreatingProcess with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp waiting for user response to CreatingProcess ""
GameAction [AppID 8930, ActionID 2] : LaunchApp continues with user response "CreatingProcess"
Game update: AppID 8930 "", ProcID 10460, IP 0.0.0.0:0
>>> Adding process 10460 for game ID 8930
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to WaitingGameWindow with ""
GameAction [AppID 8930, ActionID 2] : LaunchApp changed task to Completed with ""
ERROR: ld.so: object '/home/ktt73/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/ktt73/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
>>> Adding process 10461 for game ID 8930
Game update: AppID 8930 "", ProcID 10461, IP 0.0.0.0:0
Setting breakpad minidump AppID = 8930
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198010142306 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20181214221845)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Fontconfig warning: line 5: unknown element "its:rules"
Fontconfig warning: line 6: unknown element "its:translateRule"
Fontconfig warning: line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 8: unknown element "description"
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 76: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 76: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 84: saw unknown, expected number
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 34: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 35: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 5: unknown element "its:translateRule"
[0105/121323.941385:INFO:crash_reporting.cc(239)] Crash reporting enabled for process: renderer
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
JS method call WebChat.GetOverlayChatBrowserInfo with 1 arguments
JS method call WebChat.GetOverlayChatBrowserInfo with 1 arguments
Game removed: AppID 8930 "", ProcID 10461 
No cached sticky mapping in ActivateActionSet.JS method call WebChat.GetOverlayChatBrowserInfo with 1 arguments

Danke fürs lesen und eventuell Antworten

Liebe Grüße KTT73


#2

Hi, heisst das es startete zuvor auf Manjaro?

Es gibt einen Bugreport über das Problem, welches scheinbar überwiegend Arch Nutzer betrifft. https://github.com/ValveSoftware/steam-for-linux/issues/4483

Habe das Spiel selbst nicht daher kann ich es nicht testen, aber sollten die im Bugreport erwähnten Workarounds nicht funktionieren, so würde ich Steam via Flatpak installieren und testen ob es damit läuft.


#3

Hi,

ob es auch schon unter Arch bzw. Manjaro gelaufen ist, ist eine gute Frage, ich hatte in letzter Zeit einige Distros ausprobiert, es ist eigentlich immer gelaufen. Muss dazu sagen, das ich es jedoch lang nicht gespielt habe.

Wenn ich CiV5 in der Konsole starte wie im Bug Report geschrieben, erhalte ich folgende Meldung:

[ktt73@KTTs-Kiste ~]$ ~/Spiele/SteamLibraryLinux/steamapps/common/Sid\ Meier\'s\ Civilization\ V/Civ5XP
/home/ktt73/Spiele/SteamLibraryLinux/steamapps/common/Sid Meier's Civilization V/Civ5XP: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

Die “libcrypto.so.1.0.0” ist im selben Ordner vorhanden. Das Verhalten ist das selbe wie über Steam gestartet.

Was meinst du mit Steam über Flatpak installieren?

Edit: hab’s schon gefunden, https://wiki.archlinux.org/index.php/steam#Alternative_Flatpak_installation

LG KTT73


#4

Hast du zufällig die Steam Startoption ganz unten auf der Seite im Bugreport probiert:
LD_PRELOAD="/usr/lib32/libopenal.so.1" steam-native

Die Flatpak Version von Steam ist direkt von Valve also dem Hersteller. Persönlich habe ich damit bessere Efrahrung gemacht als mit der Manjaro Version.

Um von der Flatpak Version aus Zugriff auf die installierten Spiele zu haben, den folgenden Befehl anpassen:
flatpak override --user --filesystem=/pfad/zu/deinen/installierten/spielen com.valvesoftware.Steam


#5

Jetzt schon :wink: , funktioniert auch nicht.

Werde mich morgen mal an das Flatpak Thema begeben und berichten…

Danke und Gruß KTT73


#6

Ein ähnliches Problem hatte ich schon mal mit einer anderen Bibliothek mit einem GOG Spiel. Die Lösung war ein Symlink in /usr/lib32 auf eine aktuellere Version der Bibliothek mit dem Namen, den das Spiel erwartet hatte. Du könntest daher mal das ausprobieren:

cd /usr/lib32
sudo ln -s "$(ls | grep libcrypto.so | head -n 1 )" libcrypto.so.1.0.0

Wenns nicht funktioniert kannst du den Link auch wieder entfernen


#7

Die Datei gibt es bei mir nicht in /usr/lib32.

[ktt73@KTTs-Kiste lib32]$ ls | grep libcrypto.so
[ktt73@KTTs-Kiste lib32]$ ls | grep libcrypt.so
libcrypt.so
libcrypt.so.1

Danke und Gruß KTT73


#8

Hm, bei mir gibts

$ ls | grep libcrypto.so    
libcrypto.so
libcrypto.so.1.1

Ich weiß leider nicht in welchem Paket die drin ist


#9

Meh. Den Text auf englisch geschrieben und dann gemerkt, dass es ja deutsch ist…
Also Civ V läuft unter dem Flatpak Steam, aber es ist wirklich sehr sehr instabil. Ich habe es in den Jahren wo ich es habe nicht einmal geschafft auch nur ein Spiel zu beenden ohne das es abstürzt. Das mag mit anderer Hardware aber anders sein.

Ihr sucht glaube lib32-openssl-1.0

pacman -Fs libcrypto.so.1.0.0
core/openssl-1.0 1.0.2.q-1
    usr/lib/libcrypto.so.1.0.0
community/cuda 10.0.130-2
    opt/cuda/NsightCompute-1.0/host/linux-desktop-glibc_2_11_3-glx-x64/libcrypto.so.1.0.0
community/teamspeak3 3.2.3-2
    opt/teamspeak3/libcrypto.so.1.0.0
multilib/lib32-openssl-1.0 1.0.2.q-1
    usr/lib32/libcrypto.so.1.0.0


#10

Habe das Paket lib32-openssl* installiert, danach den Link auf die /usr/lib32/ibcrypto.so erstellt. Leider ohne Erfolg. Werde mich nun an das Thema Flatpak begeben, wird aber sicher erst zum nächsten Wochenende was werden, melde mich.

Danke und Gruß KTT73

Edit: Eine Frage noch, muss ich vorher das installierte Steam deinstallieren oder kann ich Flatpak parallel installieren/laufen lassen?


#11

Kannst du paralell laufen lassen. Du hast dan im Menü nur eben 2 Einträgewo du nicht weißt welches zu welchem gehört :joy:

Im ernstfall aber einfach im Terminal

flatpak run com.valvesoftware.Steam   

laufen lassen, dann startet das flatpak steam auf jeden Fall. Solltest du Probleme bei der installation haben, gebe ich dir schonmal ein

flatpak update

mit auf den Weg. Ist auch hilfreich wenn du ein Verbindungsabbruch bekommst beim download.


#12

also ich hab schon 136 Stunden Civ5 gespielt, alles auf Manjaro.
Aktuell muss ich aber zum starten das hier als Launch-Option einstellen:
LD_PRELOAD=/usr/lib32/libopenal.so.1 %command%

damit startet es dann. Ich nutze das steam-manjaro Paket mit steam-native als Zusatz. Ich kann aber nichts über die Stabilität sagen, früher lief es 10 Stunden am Stück problemlos. Jetzt hab ich es nur mal gestartet ums zu testen.


#13

Das ist es, zusammen mit steam-nativ, was nicht installiert war. Übrigens wird mit steam-nativ auch open-ssl 32 mit installiert ;-).

Danke allen für die Mühen, ob es stabil läuft wird sich zeigen, flatpak werde ich auf jeden Fall auch testen.

Edit: Wie es ausschaut gibt es zwei Lösungen.

  1. Manjaro Steam Version inkl. steam-nativ Paket und der Startoption
LD_PRELOAD=/usr/lib32/libopenal.so.1 %command%

oder

  1. Steam über flatpak ohne irgendwas.

funktioniert beides.

Jetzt habe ich noch 2 Fragen :wink:

  1. Bei flatpak funktionieren Updates automatisch beim Start von Steam?
  2. Was ist steam-nativ? Hat das was mit 32-bit Versionen zu tun?

LG KTT73


closed #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.