Problem bei Verbindungsherstellung via WLAN


#1

Hallo,

ich habe Probleme beim verbinden mit einem WLAN. Gelegentlich gelingt die Verbdinfung, d.h. ich kann eine falsche WLAN Konfiguration (PW,SSID usw.) ausschließen. Das Problem tritt erst seit einiger Zeit auf, ich vermute es liegt irgendwo im Kernel begraben.
Aktuell bin ich verbunden:

[bu@bu-pc ~]$ iwconfig
wlp3s0    IEEE 802.11  ESSID:"FlowerPower"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: E0:28:6D:12:CD:0F   
          Bit Rate=72.2 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=61/70  Signal level=-49 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:132   Missed beacon:0

enp0s25   no wireless extensions.

lo        no wireless extensions.

Ich habe den Kernel 4.9.71-1-MANJARO und den 4.14.8-1-MANJARO installiert, wobei es mit dem 4.9er ab und zu funktioniert, mit dem 4.14 nie. Es scheinen alle Kernel > 4.10 betroffen zu sein, wobei der Fehler mit Kernel < 4.10 auch nicht garantiert nicht auftritt.

Nach dem Bootvorgang versucht der KDE Network Manager eine Verbindung auf zu bauen, die WLAN Einrichtung schlägt dann fehl.
Beende ich den Network Manager und starte ihn neu

sudo systemctl stop NetworkManager
sudo NetworkManager --no-daemon

funktioniert die WLAN Verbindung, allerdings auch nicht garantiert.
Wobei meine WLAN-Karte des Laptops unter allen Kerneln gleich erkannt wird:

[bu@bu-pc ~]$ lspci -nnk | grep -i net -A2 
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) [8086:1502] (rev 04)
        Subsystem: Lenovo 82579LM Gigabit Network Connection (Lewisville) [17aa:21f3]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
--
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
        Subsystem: Intel Corporation Centrino Advanced-N 6205 (802.11a/b/g/n) [8086:1311]
        Kernel driver in use: iwlwifi

Es handelt sich um ein Thinkpad x230. Ich weiß leider nicht mehr weiter, auch die Suche im Internet hat nichts ergiebiges hervorgebracht.
Einen Vorschlag die NetworkManager.conf um folgendes zu weitern:

[device]
wifi.scan-rand-mac-address=no

hat nichts gebracht.

Viele Grüße
Hoehli


#2

Das scheint der bekannte Bug in KDE zu sein.

Es gibt verschiedene Möglichkeiten das Problem zu lösen.

Das Passwort für alle Benutzer verfügbar zu machen. Der Beitrag ist in Englisch, aber es gibt ein Bild.

Eine Andere Lösung wäre den NetworkManager zu downgraden. Dazu musst du alle zum NM gehörende Pakete downgraden. Ich kann dir aber leider nicht sagen welche Version funktioniert, das müsstest du einfach ausprobieren.


#3


:de::stuck_out_tongue_winking_eye:

MfG Alex


#4

Tja manchmal sind die Lösungen doch einfacher :smiley:

Vielen Dank für eure Hilfe.

Viele Grüße


#5

Ist es wirklich so einfach? Habe es versucht und es funktioniert. Vielen dank für die Hilfe.


closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.