Probleem met Redshift


#21

voor redshift-gtk moet je ps wel python-gobject hebben geinstalleerd. was ik vergeten, is optioneel

pacman -Qs python-gobject

om te zien of je die hebt


#22

Als ik redshift cof wil corrigeren,kan ik het nergens opslaan.Helaas met geoclue is het zelfde.Telkens weer :toegang geweifegrd…en binnenhalen van qs python mislukt .


#23

what is the result of: terminal
pacman -Q geoclue2 redshift

I do not understand what you say you can not guess the result of redshift or geoclue

you installed redshift and geoclue since aur? … I remember you have packages in pamac

what result do you have with: terminal

redshift -o

geoclue2 gives error?

on my desk xfce works correctly

Look like this:

pamac info geoclue
pamac info redshift
Sugerir un cambio


#24

Suerte pregunta a los expertos

Encontre la solucion!!!:grinning::grin::joy:


#25

Sorry Google vertaler helpt me niet veel, terug te lezen denk ik dat ik porfin begreep

sudo nano /etc/geoclue/geoclue.conf

Blader nu naar het einde van het bestand en plaats daar:

[Redshift]
toegestaan = waar
system = false
gebruikers =

Doe dit dan om het bestand op te slaan:

Houd de control-toets ingedrukt en druk op de letter “o”
[controle] + [o]
vraag om de bevestiging, druk op “enter” (enter)
[Enter]
laat nano achter:
houd de controle ingedrukt en druk op de letter “x”
[controle] + [x]

ok?
Dus voor geoclue automatische configuratie
Voor handmatige configuratie:

nano /home/saman/.config/redshift.conf

plak de inhoud:

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=3500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: ‘geoclue’, ‘geoclue2’, ‘manual’
; type ‘redshift -l list’ to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: ‘randr’, ‘vidmode’
; type ‘redshift -m list’ to see all possible values.
; ‘randr’ is the preferred method, ‘vidmode’ is an older API.
; but works in some cases when ‘randr’ does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type ‘redshift -l PROVIDER:help’ to see the settings.
; ex: ‘redshift -l manual:help’
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=52.33
lon=4.88

; Configuration of the adjustment-method
; type ‘redshift -m METHOD:help’ to see the settings.
; ex: ‘redshift -m randr:help’
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust all screens.
[randr]
screen=0

en nogmaals hetzelfde:

[controle] + [o]
[Enter]
[controle] + [x]

Was dat wat niet werkte?, Sorry

PD: change this location:

 manjaromanyarolibre:
lat=52.33
lon=4.88

for yours


#26

Sorry Google translator does not help me much, reading back I think I understood porfin

sudo nano /etc/geoclue/geoclue.conf

Now scroll to the end of the file and place there:

[redshift]
allowed = true
system = false
users =

Then do this to save the file:

Hold down the control key and press letter “o”
[control] + [o]
ask for the confirmation, so press “enter” (enter)
[intro]
leave nano:
keep pressed control and press letter “x”
[control] + [x]

okay?
So for geoclue automatic configuration
For manual configuration:

nano /home/saman/.config/redshift.conf

paste the content:

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=3500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: ‘geoclue’, ‘geoclue2’, ‘manual’
; type ‘redshift -l list’ to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: ‘randr’, ‘vidmode’
; type ‘redshift -m list’ to see all possible values.
; ‘randr’ is the preferred method, ‘vidmode’ is an older API.
; but works in some cases when ‘randr’ does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type ‘redshift -l PROVIDER:help’ to see the settings.
; ex: ‘redshift -l manual:help’
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=52.33
lon=4.88

; Configuration of the adjustment-method
; type ‘redshift -m METHOD:help’ to see the settings.
; ex: ‘redshift -m randr:help’
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust all screens.
[randr]
screen=0

and again the same:

[control] + [o]
[intro]
[control] + [x]

Was that what was not working ?, sorry

PD: change this location:

for yours


#27

Alle eerst hartelijk dank voor de moeite.Ik heb al je aanwijzingen gevolgd.
1.Op terminal:Geoclue2 2.4.12-1
2.redshift 1.12-2

3.Stappen met “redshift ging perfect,maar met “geoclue”,aan het einde,toen ik Controle+o deed,las ik de volgende:
Map home/saman/.conf bestaat niet.
Dat zou te maken hebben dat ik in mijn computer als “Sadegh”-mijn echte naam-geregistreerd sta en niet op mijn roepnaam"Saman”.
Ik heb geprobeerd een nieuwe map te maken in :home-sadegh,maar dat mislukte,omdat bestandenbeheer “./” niet accepteerd.


#28

Ik ben erg blij dat het voor je werkt en als je de naam “saman” verandert voor je echte gebruiker …

nano /home/Sadegh/.config/redshift.conf

feliz dia en Nederlands


#29

die configuratie van /etc/geoclue/geoclue.conf van hierboven moet je niet vertalen, dat moet in engels blijven anders krijg je zoiezo fouten