Probleem met Redshift


#1

Beste mensen,
Ik gebruik Manjaro 17,xfce,de nieuwste versie .Ik kan redshift maar niet starten.Ik lees steeds dat profiver ,de locale informatie niet kan ophalen.En dat terwijl ik zowel Redshift als Geoclue2 heb geïnstalleerd.
Wat moet ik meer doen om Redshift aan het praten te krijgen?


#2

Añadir a /etc/geoclue/geoclue.conf:

[redshift]
allowed=true
system=false
users=

In notification ask if you want to allow geo, if you answer yes before the message is hidden

Happy day


#3

Hi,
Alle pogingen ten spijt.

  1. Nadat ik “Geoclue” heb geinstalleert,kan ik nergens het knopje daarvan vinden .
  2. In pakketbeheer staan,zowel bij algemeene deel als bij “AUR”,vele pakketten van Redshift en Geoclue.Ik probeer alles maar het levert -nog - geen resultaat op.

#4

I do not understand, do not you find the “redshift” button in menu?

Instala desde pamac:

feliz dia
Happy day


#5

I don’t understand much of what the problem exactly is in this thread… However, make sure that redshift-gtk is in autostarted on your system.
Also you may need to add this to your /etc/geoclue/geoclue.conf :

[redshift]
allowed=true
system=false
users=

#6

Ik heb alles gedaan wat je zei,maar resultaat is hetzelfde.
Bij etc/…de tekst van [redshift]…in mousepad getypt,geweigerd.


#7

open terminal

sudo nano /etc/geoclue/geoclue.conf

at the end of the file

[redshift]
allowed=true
system=false
users=

at the end of the file


#8

Nee,helaas.Ook dit heeft niet geholpen.:roll_eyes:


#9

as in the last image of “nano”

then restart to see if it works

suerte y feliz dia…pregunta a oberon y compañia sabran decirte mejor que yo


#10

maybe this one works for you:

menu> search for notifications> turn it on and check …“geoclue”

after (always and everything) in register

last: menu> redhift

notifications will ask you if you let redshift connect

suerte I try easy way


#11

geoclue heeft ook een Agent die moet dan ook geladen worden tijdens opstart… geloof die staat ook in je opstart moet je kijken of die is aangevinked anders moet je bij Redshift je coordinaten direct ingeven van je regio.


#12

met http://www.geonames.org/ kan je dinges krijgen waar je woont

kun je gebruiken als https://wiki.archlinux.org/index.php/redshift#Quick_start

Maar als je geoclude gebruikt zoals de antwoorden hierboven moet normaal kunnen werken. Maar geoclude moet wel geladen zijn anders kan redshift ook niet zijn werk doen


#13

ok ok

Terminal: redshift -l 52.33:4.88 -t 5700:3600 -g 0.8 -m rar -v

And how does it work?

activate geoclue as you told ringosleeps


#14

Nee…


#15

Nee,helaas.Zou het iets met xfce te maken hebben?


#16

good day saman

I’m running out of ideas …

try this to see if it works by chance

Open mousepad and paste the content you see:


; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=3500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: ‘geoclue’, ‘geoclue2’, ‘manual’
; type ‘redshift -l list’ to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: ‘randr’, ‘vidmode’
; type ‘redshift -m list’ to see all possible values.
; ‘randr’ is the preferred method, ‘vidmode’ is an older API.
; but works in some cases when ‘randr’ does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type ‘redshift -l PROVIDER:help’ to see the settings.
; ex: ‘redshift -l manual:help’
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=52.33
lon=4.88

; Configuration of the adjustment-method
; type ‘redshift -m METHOD:help’ to see the settings.
; ex: ‘redshift -m randr:help’
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust all screens.
[randr]
screen=0


save the file (redshift.conf) and copy it:

/home/saman/.config

suerte y feliz dia…


#17

Nee…tot mijn spijt, zie ik hetzelfde blokje met er op : Gevaald…


#18

Ben ook beetje kijken in virtualbox weet de probleem nog niet exact zal wel zien … :slight_smile:


#19

heh ja, na wat kl*ten in vbox werkt het toch nog wel, in sessie & autostart moet je in Xfce een geoclue Demo Agent. Want dat een locator, die bepaald in welke lengte en breedte waar je op dit aardbol bevind. zo weet men ook of het donker word of niet. die moet aangevinked zijn. ik had redshift-gtk als autostart maar dat moet niet dat werkt zoiezo al niet. Als je de Geoclue agent als autostart hebt moet je als je opgestartbent doe je alt-f2 en doe redshift-gtk , je ziet een notify opkomen, die vraagt of jij je locatie mag doorgeven. Als je ok of ja aangeeft moet die redshift werken en in de panel zien.

en daarom om die notify te verbergen moet men iets toevoegen om toegang te verlenen : https://wiki.archlinux.org/index.php/redshift#Automatic_location_based_on_GeoClue2

is echter root dus sudo nano /etc/geoclue/geoclue.conf
als voorbeeld een welke editor je wilt :slight_smile:
dit moet echter onderstaan in die conf bestand

[redshift]
allowed=true
system=false
users=

Maar wil je zonder geoclue werken dan word het wel wat ingewikkelder dan is echte rmanueel invoeren dat is ander staartje…

zorg dat geoclue agent is autostart, als je erin bent start je redshift-gtk met alt-f2 dan vraagt die voor bevestiging , als in autostart staat dan werkt het niet juist als je boven hebt ingevoerd dan kan je altijd gewoon proberen met redshift in autostart dan is voor verder stadia, zou eerst zo kijken… heb beetje gekeken in vbox eerst leek fout the lopen maar ik deed denk zelf ook fout.


#20

Hoi,

Overigens is het handmatig invoeren van de coordinaten makkelijker dan je denkt…
Je kunt in google maps heel makkelijk de lengte en breedtegraad opzoeken van je huisadres.

Dat kan je dan in je redshift config invullen en voila…heb je geoclue niet nodig.
Ik gebruik de KDE desktop en heb in de taakbalk het redshift control widget. Ik gebruik dat om mijn adres coordinaten in te vullen en alles werkt.

Veel succes.