Printing service broke with this week's updates

Ran updates this week on Manjaro stable.
Lost my printer. Tried to add printer but the print service was reported not running.
Gave it password while attempting to start and connect, it offered local host to connect, and still failed with ’ cups error failed to connect to server’

Is there a fix? Thanks.

1 Like

Have you tried to enter the following command in a terminal window

systemctl enable --now cups.service
systemctl enable --now cups.socket
systemctl enable --now cups.path

Thanks Wollie; your suggestion got it working. I am afraid I do not understand much at all about printing. Is there somewhere I could read about this to understand how cups works?

Until someone fixes what is broken in the updates, I’d guess I need to do this each time I reboot?

As an aside, this past year or so the printer kept becoming un enabled on its own, my wife’s laptop could not print to it, and I would have to go in and enable it. Is that also a bug, or is there a setting I need to tend to?


1 Like

No. This change should be kept, even on reboots.
The reason it “broke”, was that the filename of the service, socket and path files have changed in the recent cups.

My printer also had vanished, luckily checked forum before messing anything by my own :sweat_smile: Thanks for help!
(it was odd that cups didn’t allow reinstall printer even the pdd.gz for printer was available, software claimed that no it wasn’t there :sweat_smile:)

The best reference I found is in Manjaro’s wiki:

1 Like

Thanks, worked for me to. But Why ?

Some path and service names have been renamed in upstream, if you want the details have a look here:


Thank you Wollie. It did keep on reboots, and is working now after recent updates this Month.

The links are a good start, thanks. I betray my frustration at seeing how to move from a casual user, and when needing help being a bit of a plug and fixer, toward seeing why the fix actually works, be it printing, the desktop, or whatever. The info I find can be very useful if I find the right info, but often is not understandable to a beginner… lots of detail but not much structure towards working systems. And I do not mean details of the coding choices, just what are the working parts and how do they interact, be it printing, a desktop, a file manager, or whatever. I have seen very few manuals that even briefly explain why for entries, but it keeps the manual shorter and is mostly a good start. And of course, these are moving targets to some extent.

I did not mean to offend when I say something “broke”. But a $40,000 car is not working even if it is just runs out of fuel. And despite all good efforts, if it no longer works, a functional problem has been created. I have found software gets changed mostly for the better; not all effects are always immediately foreseen. And if the system has multiple components each developed by different groups, coordination is an interesting challenge. Thankfully , generous people devote time for development, and aid.

I appreciate your help.

1 Like

Thanks for the systemctl fix, I stressed for days since I have some legal docs to print and sign and this worked first try, GLAD I CAME HERE FIRST!

Thanks all.

I got printing working again thanks to your assistance, @Wollie . Thank you! :smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.