Powerlevel10k Customization

Hi there,

How can I customize powerlevel prompt without breaking other zsh and powerlevel default settings? I want to remove the Manjaro icon from the powerlevel prompt. What’ the correct way to do it?

Thank you.

OK, I was confused by powerline. Powerline is basically the opposite of P.O.E. It allows you to use electrical power cabling as network cables.

What you’re talking about is the Command line, it seems. The ZSH command line can be easily customized. I recommend looking up and looking into oh-my-zsh. It can do what you’re looking for and much more.

Edit:
Oh, and hi @randomname. Welcome!

Another edit:
I don’t know if this does what you’re looking for, but also take a look at, and consider manjaro-zsh-config:

pamac install manjaro-zsh-config

Hope this helps.

Sorry it seems to be powerlevel not powerline. I mixed up the two. Anyway it’s a zsh theme installed on Manjaro by default.

p10k configure

Try that command on terminal and follow instructions. You might have to manually touch/create ~/.p10k.zsh first tho.

Powerlevel sounds like something from sn RPG game, or a fantasy book with wizards and/or sorcerers. I have absolutely no idea what it is or could be in Linux.

Oh, cool. Didn’t know there was something with this name. But cool!

1 Like

Ok, so I found the powerlevel10k config used by Manjaro is /usr/share/zsh/p10k.zsh. Might not be the best solution, but tweaking this file solved my problem.

No, it’s not a solution at all. /usr/share/zsh/p10k.zsh belongs to manjaro-zsh-config and will be overwritten without notice the next time there’s an update.

As already mentioned, you need to run p10k configure which saves your settings to ~/.p10k.zsh. You normally don’t edit that file manually, it’s done by the script.

More info here:

2 Likes

The configure option does not work for me. It refers to the user/share/zsh location which it cannot write. Using sudo gives me the error p10k command not found.
What am I doing wrong?

+1.

Tried

$touch ~/.p10k.zsh

but that didn’t do any good either.

@basju81 @mvalkier

I can’t remember exactly what I did because it was long ago (though I remember it wasn’t without problem), but it is totally possible to do it. Try to:

sudo cp /usr/share/zsh/p10k.zsh ~/.p10k.zsh 

and the source this at the very bottom of your ~/.zshrc

[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh
5 Likes

Thanks man! this did the trick.
I do find it strange p10k is implemented for all users, but no standard option to configure it.

This did it for me, but it’s indeed strange that there’s no easy way for a user to customize Powerlevel.
It would be nice to have an easier way to remove the Manjaro branding system-wide.