Power throttling, CPU won't use all available power, weird CPU usage readings and stutter in all games

My laptop acer swift 3 314-43, with 5500u and 16gb RAM(full specs below) have performance issues in games and some weird readings about CPU usage. All games are stuttering, even with 80fps it feels like I have 15-25 and mangohud always shows “power throttling”, but more on that later.

Of course I checked that on PLATINUM level proton games, that don’t have such issues according to protondb, to be sure that it’s isn’t optimization stuff. All games have such problem, no matter FPS.

According to mangohud my CPU rarely eats more than 14-18W of power and loads over 35%, but it’s should be more. Also “throttling power” or “throttling power current” always shown.

My TDP limit is 25(it’s set correctly, I checked) and according to youtube tests I should have my actual TDP close to the limit and CPU utilization in games(same games) 10-30% higher. In benchmarks it seems… fine. Well, I checked on windows CR23(couldn’t find more benchmarks for my CPU with TDP limit of 25) and it had ~same as expected score, then I checked basemark(vulkan, medium) in there and the score was a little bit lower than I’m getting on manjaro. I’m making a conclusion that my performance would be the same in CR23(or a bit better) if I’d run it on manjaro. => benchmarks are working fine. But who knows for sure… It’s 2 different tests. Maybe my integrated GPU works at full power always, but CPU works at full only on Windows…

And a very strange thing: my performance on battery is same as on AC. Literally no changes. It’s like my laptop always thinks it’s on battery, even when on AC, and works accordingly(but judging by KDE widgets and mangohud it knows that it’s on AC).

Also might be useful: amount of RAM detected incorrectly. My laptop has 16GB, so it’s should show ~15.6, but it shows 15.

I tried: Changing CPU governor(with a lot of stuff, but on this install of Manjaro it’s Corectrl, I use it on “ondemand” cause it’s performs better than "performance). Reinstalling OS(2 times). Running memtest86+ to see if my RAM is okay(I though that stutter can be a sign of RAM problems) - nothing. Get “PASS” 3 times and turned it off. Different protons, launch parameters and etc of course, but it isn’t the problem, like I said - it’s consistent in every single game. Tried to play with TDP limit, but no matter where I set it(15w,25w,30w) - it’s always about 15 in games and rarely 15-25(in real gameplay it’s only up to 17w 80% of the time).In basemark TDP is higher on ~5w, but still not the limit, should be the limit. Turned of KDE compositor.

I didn’t do much with drivers(mesa, etc) cause to me it seems like power management issues(it’s where I spent most of the time, trying different programms).

I hope someone here knows why my laptop can’t work at his designed power(It’s default TDP was set to 25W when I bought it) and only works at 3/5 of it. Why processor is always “power throttling” and why from AC I have the same performance as on battery.

Thanks to everyone in advance.

  Kernel: 5.15.57-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=3b24eaa3-20f4-4163-8828-353ccc9dba82 rw rootflags=subvol=@
    quiet udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Swift SF314-43 v: V1.04
    serial: <superuser required>
  Mobo: LN model: Sake_CA v: V1.04 serial: <superuser required>
    UEFI: Insyde v: 1.04 date: 07/28/2021
  ID-1: BAT1 charge: 43.4 Wh (82.4%) condition: 52.7/53.2 Wh (99.0%)
    volts: 12.4 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
    status: N/A
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x68 (104) stepping: 1 microcode: 0x8608102
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 2663 high: 3644 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 2037 2: 2961
    3: 2748 4: 2964 5: 3046 6: 3242 7: 1921 8: 1946 9: 3622 10: 3644 11: 1935
    12: 1890 bogomips: 50328
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0
    chip-ID: 1002:164c class-ID: 0300
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-3:2
    chip-ID: 0408:a094 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x683d built: 2019
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.42 5.15.57-2-MANJARO)
    v: 4.6 Mesa 22.1.4 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Acer Incorporated
    ALI driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Acer Incorporated
    ALI driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.57-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: tap-easytether state: down mac: <filter>
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 192.18 GiB (40.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: EDFK0S03
    temp: 37.9 C scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 192.18 GiB
    (40.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 192.18
    GiB (40.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 192.18
    GiB (40.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Alert: No swap data was found.
  System Temperatures: cpu: 40.4 C mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (RPM): N/A
  Processes: 394 Uptime: 42m wakeups: 123 Memory: 14.98 GiB used: 3.36 GiB
  (22.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: apk: 0 pacman: 1320 lib: 399
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.20

Welcome to the forum! :wave:

Please edit your post and paste the text, not screenshots of text.

Please see:

I can’t post text, site says me that I’m trying to send a link when I paste output of “inxi -Fza” and not allowing me to send it.

It will work if you use Preformatted text as outlined in the tutorial above. :wink: