Power saving and Refresh rate glitches


Installed fresh manjaro kde on precision 5470 with 12th gen 12800H cpu.

During the boot (dell logo) the right side of the screen starts flashing, like this post.

This glitch occurs on 60hz only on both wayland and x11. As soon as I plug into a dock with 2 external monitors, the issue disappears. Also the issue disappears if I set to 48hz refresh rate.

The solution in the post linked above, is to set i915.enable_psr=0 this disables power management of the gpu and is not a permanent solution, especially since it helps degrade the laptop battery.

I am looking for some hints at how I can resolve this :frowning:

Below are the drivers and exact version of manjaro.

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Kernel Version: 6.1.30-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 20 × 12th Gen Intel® Core™ i7-12800H
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: Dell Inc.
Product Name: Precision 5470
pacman -Qi mesa-vdpau                                                                          ✔ 
Name            : mesa-vdpau
Version         : 23.0.3-1
Description     : VDPAU drivers
Architecture    : x86_64
URL             : https://www.mesa3d.org/
Licenses        : custom
Groups          : None
Provides        : vdpau-driver
Depends On      : libdrm  libx11  llvm-libs  expat  libelf  libxshmfence  libexpat.so=1-64
Optional Deps   : None
Required By     : None
Optional For    : mesa
Conflicts With  : None
Replaces        : None
Installed Size  : 12.22 MiB
Packager        : Mark Wagie <mark@manjaro.org>
Build Date      : Fri 21 Apr 2023 10:29:58 PM EDT
Install Date    : Sun 28 May 2023 01:55:56 AM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : SHA-256 Sum
mhwd -li                                                                                                                                                                                                                     ✔ 
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

You could try setting up a udev rule to load the module, or unload the module, when connecting to the dock…



That makes it semi-permanent…it might get resolved and then deleting the udev rule is easy.

Can you expand on what module and why would I want to load unload something when connecting to the dock?

Sorry. No. At least not at the moment. Not at my PC.

But see if there’s anything about it in the Arch wiki.