Postgressql install and first run [Solved]

Hello everyone,

I am glade to be part of this community. I started using Manjaro like 2 months now.. So here is my first wall ahead which I want to break through,

I installed Postgressql from the green ghost (octopi).. installation went smooth. so I installed pgadmin4
so I started the pgadmin4 from the Icon on the menu, and it asks me for password, I tried my (user sudo password) as during installation there was no question for password. but it fails..

I tryed to log then from the terminal but also no luck
so someone please direct me to the solution
thanks in advance

Did you configure postgresql after installation?
Try following the arch wiki: https://wiki.archlinux.org/index.php/PostgreSQL#Initial_configuration

thank you for the responde I follows the steps
but can not create user

Blockquote

createuser: could not connect to database postgres: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/run/postgresql/.s.PGSQL.5432"?

Blockquote

Did you start postgres after installation?

$ systemctl start postgresql

thanks man
do I need every time to start this or it will be available next boot??

This would only start (once). To start and enable a service use

$ systemctl enable --now postgresql

Thank you I make the Post by Solved

Forum kindly sponsored by Bytemark