Postal Redux doesn't open

Hi, I recently downloaded Postal Redux and it isn’t launching. The game has a Linux port. I made the developers aware of this and sent them logs and my system info, but I’ve been told by other users that it may be an issue with my iGPU and that I should try asking here too just in case… so this is the thing. I just press “Play” on Steam and after a second or so the game closes without any error message, just like that. There really ain’t much more to it. Here’s a video: Video

Here’s the log of the game:

And here’s my system info:

Any help is greatly appreciated.

Try to verify your game files through Steam first Verify Integrity of Game Files - How To's - Knowledge Base - Steam Support

I see something weird in your game log:

[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.

So if verifying the files doesn’t work, try to do as told, and create a file named steam_appid.txt in folder /home/tralph3/.local/share/Steam/steamapps/common/POSTAL Redux/Engine/Binaries/Linux/ with the content 401680 which is the AppID of this game on Steam. Once the file is created in that folder, try again.

Another thing to try, start directly the game from the folder /home/tralph3/.local/share/Steam/steamapps/common/POSTAL Redux/Engine/Binaries/Linux/ there should be a file called that you can start from terminal or maybe directly from your graphical file explorer (also can you post the content of this file I think I’m onto something…).

But you issue is maybe your integrated video chip, maybe it doesn’t have enough dedicated memory, or maybe it is not compatible with the game. Maybe someone will have another idea to try though.

//EDIT: also what version of Steam do you use? steam-manjaro or steam-native?

Well there’s a lot to unpack here. I didn’t know there was a Steam Manjaro version, and I wouldn’t know how to check what to use. I launched Steam on the terminal with the --version flag, and it seems to have ignored it but anyway here’s the first few lines, might answer the question:

Regarding the other stuff, I already tried to verify cache integrity, and I have actually reinstalled the game multiple times to no avail. I also have played this game before on Windwows, so the chip itself shouldn’t be the problem.

About the steam_appid.txt thingy, I had actually done that some weeks back when I was trying to debug this myself and it didn’t work, I’ll do it again anyway to give more logs and more info.

So, here’s the logs: with the steam_appid:
POSTAL Redux/PostalREDUX/Binaries/Linux/PostalREDUX-Linux-Shipping (no steam_appid):
POSTAL Redux/PostalREDUX/Binaries/Linux/PostalREDUX-Linux-Shipping (with steam_appid):

And lastly, here’s the contents of the script:

UE4_TRUE_SCRIPT_NAME=$(echo \"$0\" | xargs readlink -f)
chmod +x "$UE4_PROJECT_ROOT/PostalREDUX/Binaries/Linux/PostalREDUX-Linux-Shipping"
"$UE4_PROJECT_ROOT/PostalREDUX/Binaries/Linux/PostalREDUX-Linux-Shipping"  $@ 

Hope this helps.

Opt out of the Steam BETA client (why did you opt in the beta? any reason?) and see.

Nothing. I opted quite recently, and as I sated I had tried to troubleshoot this before myself. I also tried to use Steam’s runtimes but nothing. I opted because I prefer to have the latest features, but I never had a single issue because of it, and I never heard that Steam itself was causing a problem with games not opening, even less so that the beta didn’t work but stable did.

You never heard but that’s quite possible nonetheless. It’s called a BETA client for a reason.

Still, did nothing.