Post Update May 13: Screen suddenly froze

I suppose this is relevant to the update from May 13. I haven’t had the time to update until today. Everything seemed perfectly fine, except that when I logged in after the update, the normal, rotating “broken circle” was replaced by a black, rotating “square” with parts of the circle on it. Not sure how else to describe it.

I used the TTY method to update, no errors I could detect.

Moving to the next step here. AUR updates. I had eight of them to fix so I used the GUI installer, I am not sure how to install updates for AUR packages some other way.

Everything went fine until about 1/3 or 1/2 or something of some qt5 webkit update was compiling, and suddenly the screen turned black and I moved the mouse to avoid the system getting locked. That’s when the screen froze.

Those AUR things were installed by some programs I installed before.

The computer still responds to mouse movements (or a keyboard click on, e.g., an arrow key) but I get nothing I can work with, no login box, nothing. All I see is a lighthouse, some gulls and a sailboat of some sort.

Assuming the compiling of that AUR thing is going on on the background and I am not sure for how long it will, last time it took hours, how do I move forward from here?

I’m currently using my Tuxedo laptop to write this.


I had an epiphany and hit Ctrl-Alt-F3 and lo and behold that worked.
Did a reboot, just to see what would happen, and it’s back up again. Not sure what happened with the compiling of that webkit thing-a-ma-jig:
“qt5-webkit 5.212.0alpha4-22 → 5.212.0alpha4-23
Classes for a WebKit2 based implementation and a new QML API”
Any suggestions on what I should do with it?
Not install it and try and find the culprit that installed it behind my back and uninstall that also? Other ideas?


Do you have a reason for these AUR packages that are failing to compile?

pactree -r qt5-webkit


pacman -Qi qt5-webkit

I am not convinced it’s the packages that fail to compile. My system went into lock mode, while they were compiling, and that’s when the screen froze.

Are you suggesting that compiling while using pamac GUI would cause this? It had already installed other bits of AUR stuff, this one was the last on the list and it wasn’t installed yet.

Aha, your pacman command revealed that it was ultimately the markdown editor “Remarkable” that dragged it in. I might as well uninstall “Remarkable.” I don’t use it that often.

That will save about 2-3 hours compile time when that thing is updated.

I’ll check the stability of the system for a day or so, so I’ll leave this unsolved for now. “I’ll be back.”

Without more information I dont know for sure.
I avoid pamac in general and would warn others to do so as well.
But when it comes to the AUR - its especially known to have problems.
(yes, including crashes, yes failing to compile, yes having a stroke if user interaction prompt is forwarded)

IF you need those packages I might suggest using another AUR helper or the manual makepkg method.

Beyond those things though I was questioning whether you actually need those packages.

Ah. Then that is the answer.
The package is flagged out of date but has had a patchy history:

Hmm, why is pamac installed on the system if it only causes problems for people? :confused:

For what it’s worth, I have never before had a single problem that I could say pamac is to blame. It has previously always done what it should, even full system upgrades. But, there is, of course, a first for every event. Granted, I seldom change things around much or do much of system work with the machine. I am first and foremost a user of applications and the reason I chose Manjaro was it’s GUI and the updates of applications. Keeping track of those alone is a full-time job. I used LinuxMint for many years but was always frustrated with the lack of updates of the applications. It ran as it should, but the version of, e.g. GIMP was years behind. Starting to install everything manually, keeping track of packages and dev stuff isn’t something I am interested in. I program a little in Python, but that’s all. I’m glad others are interested in the low-lever tech stuff. Instead I just open up my wallet once in a while and pay the project a portion of its contents.

I’ll look into that “makepkg” thing and see if it’s worth it, or if there are other helpers that might be more useful.


Its the default package manager on manjaro.

That does not mean it is universally loved.

But there have been specific problems when using it with the AUR - the AUR is officially unsupported and targeted at Arch after all.

(here is another recent example I didnt even mention: Pamac problem with AUR)

Its OK if you just want to be a ‘user of softwares’ … and arguably that is what pamac is for.
Its just that because something is easy to use does not mean its necessarily easy to live with.

The AUR is intended for Arch users - it will not be something you can just use without manual intervention, and will not likely be a great experience on Stable Branch (too far from Arch). All the more so if you use pamac and depending on the number and status of packages.

Maybe there is less reason to question the use of pamac if the AUR packages are kept to a minimum or eschewed altogether.

For an introduction to the manual makepkg method I will show how it would work for the qt5-webkit package;

Make sure to have the prerequisites and sync/update:

sudo pacman -Syu git base-devel

Get the PKGBUILD and all:

git clone

Navigate to package directory and build/install:

cd qt5-webkit && makepkg -sric

Here is the wiki page on the AUR as well:

Well, this sounds somewhat silly. If it really is the default, and it also is the thing that tells people there is stuff to update, it really should be looked over and bugs eliminated. Why? Because as a user it is impossible to know, unless you experience some kind of glitch and start investigating, or you are told upfront that “don’t do that.” Those who have experienced problems know and they also (probably) know what they are supposed to do to rectify the issue. However, a user coming to a system from someplace else, where the norm was “use the updater to update your system”, as it was on Mint, one does not expect it to be any different on Manjaro/Arch.
The application looks a little different, but does essentially the same thing. But the two are clearly vastly different. Perhaps the person responsible for pamac’s maintenance could add something to it, that when the mouse pointer hovers over its icon says something like “Do not do full system upgrades using pamac!” Or can one add such a comment somewhere on the system?
Now all it says is “8 available update” [sic.] Grammar isn’t its forte…or maybe counting? This, too, should be looked at. :wink:
Example in Python:

>>> updates = [1, 2, 3]
>>> textout = f"{len(updates)} available update{'s' if len(updates) > 1 else ''}"
>>> textout
'3 available updates'

>>> updates = [1]
>>> textout = f"{len(updates)} available update{'s' if len(updates) > 1 else ''}"
>>> textout
'1 available update'

The problem would go away completely if it simply was worded differently: “Available Updates: <some number>”

I digress. I will mark your first answer as the solution, since it triggered the investigation into where the problem might be. The system has worked fine since the last 10 or so hours, although I did turn off the screen locking thing. I’m the only one here so I really don’t need it.

Thanks for your suggestions. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.