Post kernel update woes

I’ve done this a few times now, and the results are all the same. I have only experienced this on my laptop though, and not on my mini-PC. I’ve done a lot of searching and such, but it all ends the same way: reinstalling Manjaro and hoping it won’t do it again.

After the latest install, there were a list of updates, which attempt a message about the kernel being outdated and unsupported. Hesitantly I update the kernel (both through CLI and GUI), once that downloads and I reboot, I now see the list of text of processes that load before the logon screen is presented.

Once logged in I am told that I need to remove the old kernel, which I do (again both CLI and GUI). I am running 5.15x kernel right now.

I find that I cannot restart/reboot the machine afterwards. I have to ‘hard power down’ when I need for that to happen, and again I see a list of processes unloading but ultimately not rebooting.

I’ve run the grub-update command as well.

I really love Manjaro, but I also need a working laptop. Can someone please help?

Why did you use both CLI & GUI? You only need to use one or the other. I am wondering if you did something totally wrong or not.

I typically just only use the GUI to change kernels.

Do you have an LTS kernel installed? You should always have at least 1 LTS kernel installed, such as Kernel 5.10. It’s always good to have 2 kernels installed at the same time that aren’t EOL.

If not, you’ll have to boot into a LiveISO, chroot into your current installation, and install it.

1 Like

I didn’t lose either, sorry that I confused you with that.

I have tried updating through CLI and GUI, just to see if one or the other is better/worse.

I don’t have an lts version installed, it wasn’t installed with any of the newer versions.

They probably had an EOL kernel installed, and iirc, the CLI recommends you to remove the EOL kernel. Or maybe it was a popup notification, I don’t remember.

1 Like

^^ that

Oh right, sorry, I forgot there’s a warning for them when that happens. It’s been a long time since I had a kernel installed right up to it’s EOL.

Boot into a Manjaro LiveISO, and use manjaro-chroot, then install kernel 5.10 via mhwd-kernel (mhwd-kernel -i linux510)

Then you should be able to boot into your installation with kernel 5.10

Well actually… I read your post wrong… you can boot into your computer. You just can’t restart or reboot. So… just install 5.10 haha

510 LTS is installing right now via GUI on the desktop. So I’m guessing we have to tell the OS to use the LTS and not 514?

In GRUB, before you actually boot into Manjaro, you can select a different kernel by going to Advanced options. Keep Kernel 5.15 installed as well, and maybe the newer updates will fix your issue.

That option there, I never see a grub menu to select a kernel. How can I achieve this?

Ah, your grub is probably set to bypass the menu. You can go to /etc/default/grub and put in/edit to GRUB_TIMEOUT_STYLE=menu

Though pressing Esc during start up should bring up the menu as well.

OK, made that change and as soon as I can will issue a restart. I have a process working right now that I need to not interrupt.

OK, did a reboot, and no grub menu at all.

Make sure that you have the following line near the top of /etc/default/grub. :arrow_down:


Then run… :arrow_down:

sudo update-grub

Please have a look at:

Please read the original post where I detail that I have accomplished the update by GUI and by CLI. Your post didn’t help much, sorry.

Silly me forgot to update grub in-between making that change and rebooting, thanks for the reminder.

I now have the grub menu which allows me to select a kernel, going to select 5.14.21 64-bit and see what happens with that.

We now are running 5.14.21-2 with 5.10 LTS and 5.15.6-2 installed.

At bootup I didn’t see the wall of text like I usually do, going to try to reboot and see what happens there.

Should I keep 5.15 version installed if I am using 5.14?

5.14 is EOL and will soon be removed from the repos. 5.15 is an LTS kernel ─ long-term support ─ so it’s good to keep that around.

Good to know.

So I am assuming that I should run 5.15 instead. However, I am happy to report that as I previously mentioned, the wall of text before the UI loads is now hidden, and the reboot function is working as intended as well.

You guys helped me quite a bit, which is a big reason to choose this version for an OS. I’ll restart with 5.15 and see what happens.