PortAudio library issue with new alsa-lib 1.1.7


#1

Hi,

I’ve noticed some issue with portaudio after updates, applications which uses this library don’t play sound to pulseaudio eg. Audacity now works only with hw:0,1.
I check on 3 machines with different hardware and it look like real issue.


Applications not recognizing soundcard correctly
#2

Same exact issue here. Audacity is broken on 3 different machines since updates were installed last week. Cannot play play or record audio. Tried to downgrade Audacity and pulseaudio to previous versions, but it’s still broken.


#3

I’ve found solution for now, downgrade alsa-lib to 1.1.6 and portaudio library is working again.


#4

Same for me. This is a new issue. I get an “error - device not found” when I try and record in Audacity. If I restart my computer I’m be able to record with my external mic, but if I stop the recording, I get the error

I downgraded alsa-lib to 1.1.6 and it still didn’t work. Not sure if I should have restarted my computer after that downgrade…


#5

My issue seems to have been fixed with the 11/7 stable update. In that update, I reinstalled alsa-lib 1.1.7. Perhaps that reinstall did the trick. I’ll keep testing - but my initial tests were a-ok!


#6

yes, downgrade to alsa-lib 1.1.6 solves the issue.
downgraded audacity to 2.2.2-3 too, as 2.3 isn’t really stable yet.


#7

Thanks. My issue wasn’t actually resolved. So I’ll try downgrading audacity.

The issue seems to be that my external mic can’t be shared by two programs. I used an external mic to chat with someone over google hangouts (so when that’s happening, the browser has permission to use the mic), while simultaneously recording myself with Audacity. I can record myself just fine when I’m not connected to the chat. But once I connect to the chat, I get an error in Audacity.

I’ll downgrade Audacity. I’ll also try different kernels.


#8

I’m having the same issue here, but I cleaned my local cache.
Odes anyone downgraded from Arch Linux Archive? Do you know if downgrading alsalib from there is secure?


#9

I also don’t have alsa-lib 1.1.6 in my cache.

I installed Fedora 29 (Xfce spin) on an old laptop. There’s kernel 4.19, alsa-lib 1.1.7, and I can record and play audio in Audacity 2.3.0 without any problems. On my up-to-date Manjaro I cannot even change RecordDevice and PlayDevice in Audacity to “pulse” - it always gets reset back to HDMI. Weird.


#10

Downgrading Audacity solved this for me. Version 2.3 is not stable.


#11

I’m having the same issue.
Wireshark and Audacity can’t play audio on my notebook and desktop. That’s a bit annoying.

alsa-lib downgrade to 1.1.6 fixes this issue for me. Maybe the 1.1.7 was accidentally built with wrong parameters or something?


#12

@fernando_a_martin, I’ve just downgraded alsa-lib from A.L.A.
As root DOWNGRADE_FROM_ALA=1 downgrade alsa-lib-1.1.6-1. And my Audacity 2.3 works fine. I can now choose pulse in Recording device and Playback device.


#13

After last Manjaro update, that includes alsalib 1.1.7-2, Audacity has pulse and default options again and sound is working. Polyphone still has sound broken but I can use it’s windows version under wine that works as nicely as the AUR vesion.