Porblema al actualizar (Resuelto)

Hola,

Al actualizar con Octopi me genera el siguiente error:

Iniciando actualización completa del sistema ...

resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
Packages (283) apparmor-2.13.3-4 appimagelauncher-1.3.1-1 appstream-0.12.7-1 appstream-qt-0.12.7-1 argon2-20190702-1
audit-2.8.5-3 binutils-2.32-2 bluedevil-1:5.16.2-1 breeze-5.16.2-1 btrfs-progs-5.1.1-1 bubblewrap-0.3.3-2.1
bzip2-1.0.7-2 ca-certificates-mozilla-3.44.1-1 calibre-3.44.0-3 cpupower-5.1-3 cups-filters-1.25.1-1
curl-7.65.1-3 dbus-1.12.16-1.2 dhcpcd-7.2.2-1 dnssec-anchors-20190629-1 dosbox-0.74.3-1 expat-2.2.7-1
faudio-19.07-1 filezilla-3.43.0-1 firefox-68.0-1 firefox-i18n-es-es-68.0-1 flatpak-1.4.1-2 freetype2-2.10.1-1
.
.
.
thunderbird-i18n-es-es-60.7.2-1 tzdata-2019b-1 udisks2-2.8.3-1 user-manager-5.16.2-1 util-linux-2.34-3
vivaldi-snapshot-2.7.1594.4-1 vivaldi-snapshot-ffmpeg-codecs-76.0.3809.38-1 vlc-3.0.7.1-1
vulkan-icd-loader-1.1.112-1 webkit2gtk-2.24.3-1 wine-4.11-1 winetricks-20190615-1 xf86-input-elographics-1.4.2-1
xorg-fonts-encodings-1.0.5-1 xorgproto-2019.1-1 xterm-347-1
Total Download Size: 48,56 MiB
Total Installed Size: 4591,48 MiB
Net Upgrade Size: 139,91 MiB

:: Retrieving packages...

(1/283) firefox-68.0-1-x86_64
(2/283) firefox-i18n-es-es-68.0-1-any
checking keys in keyring
error: megasync: unsupported signature format
checking package integrity
checking for file conflicts
error: failed to commit transaction (conflicting files)
Errors occurred, no packages were upgraded.

Comando finalizado con errores!

He probado de reinstalar la aplicación megasync y actualizar des de pacman pero me genera el mismo error.

Sabéis como arreglarlo? he buscado por Internet pero no he llegado a dar en el clavo con el comando, gracias de antemano.

Do they host this somehow via the OpenSUSE Build Service? If so, the OBS "support" for pgp-signed repositories is broken.

I don't know this information, could I fix it somehow? At least to update all my OS

Please post

cat /etc/pacman.conf

después de un tiempo que he estado fuera, he vuelto a encender el ordenador y me aparece este error a la hora de actualizar con octopi:

Sincronizando bases de datos ...

error: DEB_Arch_Extra: key "03C3AD3A7F068E5D" is unknown

y en pacman.conf aparece esto:

> cat /etc/pacman.conf
> #
> # /etc/pacman.conf
> #
> # See the pacman.conf(5) manpage for option and repository directives
> 
> #
> # GENERAL OPTIONS
> #
> [options]
> # The following paths are commented out with their default values listed.
> # If you wish to use different paths, uncomment and update the paths.
> #RootDir     = /
> #DBPath      = /var/lib/pacman/
> CacheDir = /var/cache/pacman/pkg/
> #LogFile     = /var/log/pacman.log
> #GPGDir      = /etc/pacman.d/gnupg/
> #HookDir     = /etc/pacman.d/hooks/
> HoldPkg      = pacman glibc manjaro-system
> # If upgrades are available for these packages they will be asked for first
> SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
> #XferCommand = /usr/bin/curl -C - -f %u > %o
> #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
> #CleanMethod = KeepInstalled
> #UseDelta    = 0.7
> Architecture = auto
> 
> # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
> #IgnorePkg   =
> #IgnoreGroup =
> 
> #NoUpgrade   =
> #NoExtract   =
> 
> # Misc options
> #UseSyslog
> #Color
> #TotalDownload
> # We cannot check disk space from within a chroot environment
> CheckSpace
> #VerbosePkgLists
> 
> # By default, pacman accepts packages signed by keys that its local keyring
> # trusts (see pacman-key and its man page), as well as unsigned packages.
> SigLevel    = Required DatabaseOptional
> LocalFileSigLevel = Optional
> #RemoteFileSigLevel = Required
> 
> # NOTE: You must run `pacman-key --init` before first using pacman; the local
> # keyring can then be populated with the keys of all official Manjaro Linux
> # packagers with `pacman-key --populate archlinux manjaro`.
> 
> #
> # REPOSITORIES
> #   - can be defined here or included from another file
> #   - pacman will search repositories in the order defined here
> #   - local/custom mirrors can be added here or in separate files
> #   - repositories listed first will take precedence when packages
> #     have identical names, regardless of version number
> #   - URLs will have $repo replaced by the name of the current repo
> #   - URLs will have $arch replaced by the name of the architecture
> #
> # Repository entries are of the format:
> #       [repo-name]
> #       Server = ServerName
> #       Include = IncludePath
> #
> # The header [repo-name] is crucial - it must be present and
> # uncommented to enable the repo.
> #
> 
> # The testing repositories are disabled by default. To enable, uncomment the
> # repo name header and Include lines. You can add preferred servers immediately
> # after the header, and they will be used before the default mirrors.
> 
> [core]
> SigLevel = PackageRequired
> Include = /etc/pacman.d/mirrorlist
> 
> [extra]
> SigLevel = PackageRequired
> Include = /etc/pacman.d/mirrorlist
> 
> [community]
> SigLevel = PackageRequired
> Include = /etc/pacman.d/mirrorlist
> 
> [herecura]
> # packages built against core
> Server = https://repo.herecura.be/herecura/x86_64
> 
> # If you want to run 32 bit applications on your x86_64 system,
> # enable the multilib repositories as required here.
> 
> [multilib]
> SigLevel = PackageRequired
> Include = /etc/pacman.d/mirrorlist
> 
> # An example of a custom package repository.  See the pacman manpage for
> # tips on creating your own repositories.
> #[custom]
> #SigLevel = Optional TrustAll
> #Server = file:///home/custompkgs
> 
> ###REPO for MEGA###
> [DEB_Arch_Extra]
> SigLevel = Optional TrustAll
> Server = https://mega.nz/linux/MEGAsync/Arch_Extra/$arch
> ###END REPO for MEGA###

Open Terminal

sudo nano /etc/pacman.conf

Change the line from

[DEB_Arch_Extra]
SigLevel = Optional TrustAll

to

#[DEB_Arch_Extra]
SigLevel = Optional TrustAll

Save=Ctrl+o
Exit=Ctrl+x

And make the update.

sudo pacman-mirrors -f5 && sudo pacman -Syyu

Resolved, Now I've been able to update the system, thank you very much!

1 Like