Poor font rendering in cinnamon

I just replaced Mint with Manjaro Cinnamon on a Dell Latitude E6510. I am very happy with the change that gives me access to cutting edge packages compared to Mint.

The major grief I have against Manjaro Cinnamon vs Mint is the font rendering that is sub-par. Fonts have jagged edges (especially visible on diagonals on ‘W’ and ‘M’) and there is a moiré effect (vertical rainbow-colored streaks) very visible on dark backgrounds. It is not atrocious but after having used Mint for a while it definitely hurts the eye.

Here is a screenshot I took from the Manjaro cinnamon ISO.

Changing the hinting option does not seem to have any noticeable effect.

Are others also seeing this? Is there a setting somewhere that can be adjusted?

On my desktop computer I have Manjaro KDE running and I installed Infinality to improve fonts without problem. I tried installing Infinality on Manjaro Cinnamon but I am unable to make it work. I see not effect no matter what setting I try as if Cinnamon would overwrite Infinality settings.
Does anybody have luck with getting Infinality to work with Cinnamon?

Thanks!

System:    Host: latitude Kernel: 4.8.9-1-MANJARO x86_64 (64 bit) Desktop: Cinnamon 3.2.1  Distro: Manjaro Linux
Machine:   Device: laptop System: Dell product: Latitude E6510 v: 0001
           Mobo: Dell model: N/A BIOS: Dell v: A16 date: 12/05/2013
Battery    BAT0: charge: 49.6 Wh 72.9% condition: 68.1/84.0 Wh (81%)
CPU:       Dual core Intel Core i7 M 620 (-HT-MCP-) cache: 4096 KB 
           clock speeds: max: 2667 MHz 1: 1333 MHz 2: 1199 MHz 3: 1333 MHz 4: 1333 MHz
Graphics:  Card: NVIDIA GT218M [NVS 3100M]
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@59.99hz
           GLX Renderer: NVS 3100M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.98
Info:      Processes: 160 Uptime: 1:21 Memory: 1460.0/3881.9MB Client: Shell (bash) inxi: 2.3.4
1 Like

Your subpixel rendering method is probably wrong, try choosing a different method.

@xircon Thanks, I saw that thread. The script simply automates the installation of Infinality but my point is, Infinality does seem to do anything on Cinnamon no matter what setting I change.

@torvic Can you be more specific with what you have in mind? By the way, the screenshot is taken from the latest ISO running on my laptop from a memory stick. I have not touched any setting.

Infinality shouldn’t be used anymore AFAIK.
Some of its features have been incorporated into the new freetype2 v2.7.

I don’t use Cinnamon, but SPR can be changed either by editing fonts.conf or by changing .Xresources. Possibly it can also be changed by Cinnamon’s settings manager, but as I don’t use it, I’m not sure.
Please use the search function, there are some threads here on how to do it.

@torvic Thanks. I agree with the feeling that Infinality is end-of-life. freetype2 is pretty much there now.

I found what the problem was.

The default user ~/.config/fontconfig/fonts.conf file contains

    <edit name="lcdfilter" mode="assign">
        <const>lcdnone</const>
    </edit>

I changed it to:

    <edit name="lcdfilter" mode="assign">
        <const>lcddefault</const>
    </edit>

and bingo!

IMHO it should be changed in the default settings of the distribution.

4 Likes

I agree. lcddefault should be the default. It’s even in the name! :slight_smile:

Hey, thanks to Odysseus we have some great sites to check here :

http://www.lagom.nl/lcd-test/subpixel.php

http://www.spasche.net/files/lcdfiltering/

4 Likes

@cscs Excellent resource! I will bookmark them, thanks. Especially interesting is the identification of the color order of the display (RGB, BGR, VRGB, etc.) that can be a time waster if you overlook it (I am speaking from experience here :frowning:)

Thanks for the solution. After using Mint for years this was driving me crazy. I thought it might just be my old eyes :slight_smile:

ok. will do. lcdnone was just the setting that worked best for me here… :wink:

1 Like

Is there a guide anywhere on how to change from using Infinality to freetype2? Or do I just uninstall infinality?

I wrote this instruction in another thread.

Let me know if this works for you.

1 Like

[quote=“jeancf, post:15, topic:12870, full:true”]Let me know if this works for you.
[/quote]
Yep, I also uninstalled the packages and removed the bohoomil repository from pacman.conf.

The Cinnamon fonts look like a total train wreck now, but I think that’s because I uninstalled the fonts I used for my customized configuration.

Is there any way to restore the Cinnamon fonts config to default other than going through the lenghty and timeconsuming route of finding out what fonts and fontsize is used and manually set them using the Cinnamon control panel?

@jeancf Thx man!!! I’ve been struggling with this problem for a week and then I decided to do a search in the forum. I’m glad I found your post!

Thanks A lot jeancf my OCD was acting up because of this. :sunglasses:

OMG. Thank you !!! You made my day :slight_smile:

How improve font rendering in the latest distro with cinnamon?