Plasmashell high RAM memory usage


since the Plasma 5.26.* the plasmashell process is using almost 4gb of RAM memory just by turning my computer on (with no other process opened).

Not only that, but I noticed lots of freezing happening often, I’ve been using Manjaro KDE for years and its the first time ever that the system is almost unusable, is it happening only with me or is it normal on this new Plasma version?

1 Like

Plasma 5.26 still has issues. Please read through the following thread. :arrow_down:


Hello. I had the same issues on Plasma 5.25, when i login, it starts eating ram and needs some minutes to be ready to use, and then lots of freezes (every 5-6 minutes). This problem exists almost 2 months but now it’s worse. Today i upgraded the system and got Plasma 5.26. It’s a bit more stable but it still needs 3-4 minutes to start. Is there any even temporary solution?

I’m on Plasma 5.26.4 and my plasmashell process is using 345 MB of memory.

So do you have any custom plasmoids or widgets in use?

Only these showing network speeds and CPU/Memory usage.

I removed them, RAM memory still super high, 10gb right now, I think it must be some memory leak

Update: Memory still high, I thought it worked after restart, but no.

the same i have lots of years now.
Anyway, i will reset the settings of plasmashell to check if it fixes and setup it again as i have it step by step. Which config files plashashell uses?

I tried deleting all configs from .cache regarding plasmashell, no success also.

I’ll stop using KDE after years, I’ll start using Manjaro Xfce.


Actually I found out a alternative to Plasmashell:

I just installed it, after that I logged out and on the session screen I selected to start with liquidshell.
Even after doing all this Plasmashell still startups in the background, so you will need to run:

systemctl --user mask --now plasma-plasmashell.service

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.