Plasma5- applet thermal monitor not showing CPU temperature



I installed plasma5- applet thermal monitor from octopi and configured it to show the temperature of CPU and HDD. After logout and login, it is showing only HDD temperature. CPU temperature is off.
The widget no longer loads CPU temperature on login and I have to right click the widget and get it to reload the sources.

Is there any way to troubleshoot this ?


Mentioned about it here

and a few posts after, still no solution.

There is an issue opened for it


+1 was going to mention then forgot :smiley:


This happen also with GPU temperature same problem here :rofl:

I use watch-sensors in yakuake with i want check for temperatures sometimes :smiley:


It also happened to me. I deleted and re-added the widget and it has been holding on so far…


You mean it survives reboot with working temperatures right after it loads and no need to right click Reload Temperature Sources ?


So far yeah. But it is a very simple setup TBH. Just a single read from the CPU (tdie on a ryzen).


Ah cool, but for Intel CPU it doesn’t work. Anyway, now we know more about this issue :slight_smile:


Removed, added, about to reboot… brb.

No cigar. Intel here too, had to reload temperature sources (Again).


Same here AMD FX-8350 reinstall didn’t help :smiley: but was ok try it in anyway!


Hey, i just noticed now… after i rebooted Tower from applying the latest Stable Update today, my appletwidgetwotsit IS now showing the temperatures again, without me needing to manually reload them. It’s been a bit of a while since it last behaved correctly like this. Anyone else? Also, given today’s update was “only” systemd :stuck_out_tongue_winking_eye:, is my surprise to see this working again silly or justified?


Nah unfortunately it’s still showing “OFF” here.


Here on testing is still the same and also on unstable (that i have on another rig).


Yeah, rats, just went & woke up Lappy, which i also updated a couple of hours ago just before Tower, but i’d forgotten then to notice Lappy’s widget. Looked now… Off… had to manually reload again too. I assume this Tower surprise is just a one-off fluke blip, OR, it’s the damn poultrygoose still teasing me.


Apparently there was found a fix

To modify the file manually (till the update comes to us), see this:

it loads the values 3 seconds later than the GPU and HDD temperatures shows them tho …


i have some repeatability now. Last night i applied the Stable 2019-01-23 Update on Lappy, & tonight ditto on Tower. Both PCs repeated their previously-posted behaviour re this widget… Lappy had to be manually reloaded, Tower took care of itself just fine [like in the good ol’ days].


I wonder what _ plasma5-applets-thermal-monitor_ you have installed. Is from KDE Store, AUR or the Manjaro repos? :thinking:


That one.

There’ll be another data point soon. I’ll be doing the small update that came through hours ago for the systemd 239.303+really+239.6-1 & its three associated packages, so i [assume i] will need to reboot afterwards [?]. I’ll edit this post later this evening with the results.

EDIT: Post-reboot results latest:

  1. Tower - widget auto-loaded the temps, again - yay!
  2. Lappy - widget did not auto-load the temps, so i had to do it manually again.


And both are from KDE Store?


If the only alternatives are those other two you wrote before, then the answer has to be yes… coz til i read your earlier reply i did not even know it was available in our Repo & in AUR. I would have simply installed it via the standard Plasma Add widgets... method.

Checking Pamac now, for thermal, i only see four hits in Repo:

As for AUR, there’s lots of hits but none i have installed; i assume this one is what you meant from there?
plasma5-applets-thermal-monitor-git r56.c22f2b6-1