Plasma/X11 General system lag during certain animations

EDIT (Solution): Thanks to @Kobold for mentioning multimonitor issues, I was able to fix this issue by disabling VBlank and allow flipping in nvidia settings. Seems what I was mistaking for system lag was my monitors reverting to the lowest refresh rate during the animations I mentioned I had trouble with.

I’m a newbie to Manjaro and linux as a whole, and just a week ago installed Manjaro KDE with proprietary drivers and X11 as the WM as my new daily driver. While I’ve gotten most everything functioning fine with great performance today I noticed many animations cause a lot of system lag (mouse and keyboard input locking up visually but catching up after the lagspike, system hangups during these animations). I’ve noticed it most with the following: maximizing windows, firefox video playback (especially PiP), opening a new application, the Clion code suggestions popping up, and probably more hat I’m forgetting off the top of my head.

I have tried a few options to fix this including: switching firefox to webrender (specifically for video playback issues), changing Powermizer in nvidia settings to prefer max performance, changing my CPU governor to performance mode, reinstalling nvidia proprietary drivers, and will be setting up a swap partition right after posting this. (will add edit at the top of this post with the outcome of setting up swap, just posting this now because I know I’ll get distracted if I don’t now).

I’ve included System information at the bottom of the post.

It’s worth mentioning that every game I’ve tried runs great (using proton) and experiences none of these issues, games tested include: Heavily modded minecraft, Street Fighter 6, Guilty Gear Strive, Deus Ex (original).

How would I go about troubleshooting this issue?

  Kernel: 6.9.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=5737cc19-fddb-4acf-ae99-2dc4f774da33 rw quiet splash
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 5603 date: 07/28/2020
  Info: model: AMD Ryzen 7 1700X bits: 64 type: MT MCP arch: Zen level: v3
    note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
    stepping: 1 microcode: 0x8001138
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 2111 high: 2200 min/max: 2200/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2193 2: 2194
    3: 2177 4: 2200 5: 1991 6: 2188 7: 1963 8: 1990 9: 2200 10: 2193 11: 2195
    12: 2192 13: 2055 14: 2200 15: 1971 16: 1883 bogomips: 108627
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: Micro-Star MSI
    driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DP-2,DP-3,HDMI-A-1 empty: DP-1 bus-ID: 08:00.0
    chip-ID: 10de:2184 class-ID: 0300
  Device-2: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2
    chip-ID: 046d:085c class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: N/A failed: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5760x1561 s-dpi: 91 s-size: 1605x435mm (63.19x17.13")
    s-diag: 1663mm (65.47")
  Monitor-1: DP-3 pos: top-right res: 1920x1080 hz: 60 dpi: 37
    size: 1328x747mm (52.28x29.41") diag: 1524mm (59.99") modes: N/A
  Monitor-2: DP-4 pos: primary,bottom-l res: 1920x1080 dpi: 92
    size: 531x298mm (20.91x11.73") diag: 609mm (23.97") modes: N/A
  Monitor-3: HDMI-0 pos: bottom-c res: 1920x1080 dpi: 102
    size: 480x270mm (18.9x10.63") diag: 551mm (21.68") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1660/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 1660 driver: nvidia v: 550.78 device-ID: 10de:2184
    surfaces: xcb,xlib
  Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 08:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2
    chip-ID: 046d:085c class-ID: 0102 serial: <filter>
  API: ALSA v: k6.9.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp7s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0029
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 2.27 TiB used: 387 GiB (16.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDBNCE5000PNC
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 20RL scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS100T2B0A-00SM50 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 20WD
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD10SDRW-11A0XS0 size: 931.48 GiB block-size: physical: 512 B
    logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 1034 scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%) used: 387 GiB (42.3%)
    fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 546 MiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 38.4 C mobo: N/A gpu: nvidia temp: 40 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 45%
  Memory: total: 28 GiB available: 27.34 GiB used: 6.33 GiB (23.1%)
  Processes: 387 Power: uptime: 31m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 10.91 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1553 pm: pacman pkgs: 1544 libs: 482 tools: pamac pm: flatpak
    pkgs: 9 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

I generally turn these off.
But if your system isn’t ancient then they shouldn’t really cause noticeable lag.

Your SWAP is a bit silly at 546 megs. You do have 28GB of ram. But this SWAP is not really going to be able to do its job at that size.

I notice you have BIOS updates.

Hello and Welcome to the Forum and Manjaro,
your Desktop problems could be related to Multimonitor under X11. You could try out to unplug other Monitor’s to see if this changes.

I saw other Forum Member’s reported a improvement on Wayland when using more than 1 Monitor.

But Wayland and nvidia could lead to other problems and Wayland is still under development, actually i recommend to use LTS Kernel 6.6 if you want to try out Wayland, since your Kernel 6.9 has problems with nvidia drivers and need additional settings if you want to use it.

If you want Hardware Video Codec acceleration in Firefox, you need to activate it in Grub:

In /etc/default/grub “add” nvidia_drm.modeset=1 to the GRUB_CMDLINE_LINUX_DEFAULT line:


Don’t replace anything ONLY add the nvidia command then save the file and then type this in Terminal:

sudo update-grub

Besides Multi Monitor that i don’t use, it maybe could be related to Theme/Layouts.

Did you installed Manjaro KDE fresh with Plasma 6?
So did you saw on your first start a hovering taskbar?

Sorry for not understanding but what do you generally turn off? My system isn’t ancient I would say (even though the 1st gen Ryzen processors are starting to show their age)

This was actually a failed attempt at a SWAP partition that I forgot to delete after I learned how to properly add a SWAP partition. Sorry about that lol

Thanks for the BIOS update recommendation, haven’t done that in awhile and didn’t think of it, I’m sure that’s not helping my situation my any means having an outdated BIOS.

Under System Settings > Apss & Windows > Window Management > Desktop Effects
You can disable or configure most of the effects.

Under System Settings > Workspace > General Behavior
You can set animation speed to instant which is pretty close to off.

This doesn’t seem like a failed attempt at all; it’s just seriously undersized. You should probably fix that sooner, rather than later. Cheers.

Sorry, by failed attempt I simply mean I tried to add a swap partition to my already mounted main drive, the drive I accidentally added a swap partition to is my ntfs drive that I have windows on should I ever need it (I have a crippling league addiction and use ableton for music production). I just need to add a properly sized swap partition to the correct drive is more so what I meant, thank you!

Makes sense, thank you very much I’ll see if that helps. Though This wouldn’t address the lag I experience in apps like CLion that occur when a dropdown menu appears would it?

Interesting, I do use 3 monitors (one main, one side, and one TV for media streaming and gaming) and upon unplugging all but my main monitor my CLion issues as well as the desktop effects and firefox lag seems to be resolved (albeit a VERY quick test as I have an assignment I’m working on due in about 2 hours lol). Do you know how I could further troubleshoot the Multimonitor or is this simply a known issue with X11?

I did have a hovering taskbar on my first launch as you said so I believe I am running Plasma 6. On my current installation when I try Wayland (despite the reported issues, I simply wanted to rule that out as a solution) my pc only outputs a black screen and the mouse after the login screen, only able to get out of the black screen by force rebooting and logging in with X11.

I see. If that swap partition still exists (and sufficiently sized) you can likely just change the swap reference in /etc/fstab to point to that partition, in the meantime.

Your /dev/sda might be slowing things down, generally, but otherwise nothing obvious jumps out from your listed specs. Perhaps updating your BIOS as previously suggested might improve things.

Have you considered using Wayland?


Re: Kernels (mentioned in the next post) :point_down: :point_down:

That’s why i wrote this:

There is a simple GUI to install other Kernels btw.

If you don’t want to switch your 6.9 Kernel there is another way to use Wayland:

Ah I see, sorry for the redundancy then on the Wayland thing. Thank you for the recommendations, I’ll go ahead and try these suggestions and troubleshoot Multimonitor under X11 if Wayland proves to be too problematic with my hardware.

1 Like

I’m definitely going to try out Wayland to see if it helps as it seems like it may be an X11 Multimonitor issue as Kobold suggested since there seem to be none of these issues once I unplug my other monitors. I appreciate the link to the Manjaro Kernels page, makes it easier to know I’m in the right place for it as a newbie to all this lol. Will for sure update the BIOS and report back if that seemed to solve the issue.

Appreciate the help and suggestions

Remember a Bios update could lead to a destroyed system also.
If there is no big security hole or another big issue that will be fixed from a Bios Update. Don’t do Bios updates.

The chance that a Bios update will fix your problems is pretty low.

As far as i know, only the newest AMD Mainboards allow Bios fails and reverts everything without to harm your Hardware.

I had already a long discussion with @cscs in the past and he is one of the strongest Linux Veteran here in this Forum. But his addiction to flash Bios is not always a good recommendation.

There is a good reason why MB Vendors write on their Website, copy+pasted from Gigabyte as example:

Because BIOS flashing is potentially risky, if you do not encounter problems using the current version of BIOS, it is recommended that you not flash the BIOS. To flash the BIOS, do it with caution. Inadequate BIOS flashing may result in system malfunction.

Your MB can be dead and destroyed from it… i just say, think twice if its really worth it.

I’ll definitely keep it as a LAST last resort then. I personally have never encountered issues flashing bios on other systems (worked at a repair shop briefly and did a few at the request of my boss at the time) so I honestly forgot how risky it is in my desperation to fix this, thanks for the heads up.

I personally never had problems also, i read still a good amount story’s where vendor’s uploaded the wrong Bios File, but since your MB is older… i think this risk can be excluded.

I do my safest way to flash:

  1. Never use OS Flash, only flash directly in Bios.

  2. Double check the USB Flashstick after copy the Bios file on it, restart system to clean RAM. Copy the file after restart back on your Harddrive, to make sure there is no read error.

  3. Also do a checksum and compare the checksum with the number on the Vendor’s page.

I’ll just add that in my experience, the only mainboard I’ve seen borked as a result of a BIOS update is when the user has downloaded an incorrect BIOS file (from a slightly different model).

The moral to this story is that if one is not confident in safely performing a BIOS update, ask someone who is. That is all. :vulcan_salute:

Might also be connected to 487043 – Extreme stutters/hangs when using certain desktop effects when "~/.cache" is on slow storage

This topic was automatically closed after 2 days. New replies are no longer allowed.