Plasma (Task manager) freezes if there is high load

I often experience task manager (kde taskbar) freeze in case I have a high CPU demand, for example if I have a lot of web browser videos and graphic stuff open.

In this case, clicking anything on taskbar produces no result. I can not use it and also windows of applications are not responsive.

As I have fairly equipped laptop, 64G ram, xeon, … I am wondering if there are some settings that I can tweak in order for my desktop to perform better on exceptional loads?

Thanks for support.

Check your swap settings …

That smells ‘out of RAM’ issue. Yet you claim having 64GB RAM so???

Check resources when issue happens. Is the CPU overloaded? Is the RAM full?

This happens especially when I come back after specific time, for example after a few minutes, when screen lock already occurred.

Then it last a couple ten seconds until my keyboard is responsive and am I able to enter password.

Seems like pc goes in some “hibernation” mode and takes some time to get back…

So if I increase swap (8GB), this behavior would disappear?

Doubtful. Check swap settings, and look at swappiness also - have you done anything with swap or swappiness before?

I had to update mine after switching to SSD. I brought swappiness down…
sudo sysctl vm.swappiness=20
I believe default is 50 or 60, you can check what you have now with:

cat /proc/sys/vm/swappiness
╰─ cat /proc/sys/vm/swappiness                                                     ─╯
       │ File: /proc/sys/vm/swappiness
   1   │ 20

Check FIRST before you enter a value. This stopped me having to reboot every time I messed with Firefox more than five minutes.

Perhaps I found the culprit (dmesg output).
This happens just when I leave keyboard and mouse untouched. I did not issue a “sleep” power command.
How to disable this?