Plasma panel: opacity setting is missing

I have two similar systems on different machines: Manjaro Qonos 21.2.6 + Plasma 5.24.5

The first system is two years old (has been updated many times), the second one is fresh and due to it I’ve noticed the first one is missing the opacity setting

I’ve recreated panels several times, changed their position, alignment, etc. in vain. So far this is the only difference I’ve noticed, the both systems work smoothly.

By the way, I had panel issues one year ago. Turned out some Plasma config was full of filenames and its removal solved the issues. I hope this time I won’t have to reset everything

Hi @Vitoldus, and welcome!

I don’t have such a setting either:

AFAIK it has to be set in System settingsWindow rules:


Hope it helps!

I also have that setting bloc.

Following @Mirdarthos comment, i see that bloc has been removed from the online documentation. So that “disappearance” might be intentional…
The page hasn’t been updated since 2019, and the feature was introduced in 2021…

Maybe the option is only available for relevant themes?
Do you have the issue with the Breeze themes?

I don’t actually need static opacity, but adaptive. Anyway, tried your recipe and it didn’t affect the panel, just darkens for a second after pressing ‘apply’

Changing theme doesn’t trigger this block. The both systems use ChromeOS theme and even have almost similar Desktop Effects
upd: I update this theme regularly so it’s the same version on the both machines. This issue is on Wayland too

@Vitoldus Proposal to try:

  • Add a second panel to the old system by right click on desktop > Add panel > Default Panel. It will open at the bottom. Enter edit mode of the second panel and check if the opacity options are available.
  • Try with a temporary new user profile.
  • Creating, editing, moving panels doesn’t work
  • It’s shown for the new user, like on my new system. The way I see it, Plasma didn’t upgrade old configs correctly (this feature was released with Plasma 5.22 about year ago). And the main question is where can I find panel configs to try to merge them with working ones ?

It is likely related to your config files of

  • System Settings > Appearance > Plasma Style

For example if I choose ‘Air’ or ‘Oxygen’ which are old config files the opacity settings are missing.

Try switching for Plasma Style to any Breeze temporarily and see if you get it back.
You can also reset with Defaults


  • ~/.local/share/plasma/desktoptheme/ChromeOS/metadata.desktop

You don’t want to reset your whole theme and start over again, is it :wink: .


That worked, thanks for help.

  1. Added this option to config
  2. Selected Breeze theme
  3. Selected ChromeOS theme and now I’m able to change its opacity too
1 Like

A post was split to a new topic: How to change panel transparency?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.