Plasma 5.25.5 theme issue

After updating to plasma 5.25.5 my color scheme for firefox itself and file save dialogs in firefox/brave/vscode are changed to breeze-like (not my selected system theme), e.g.:

And that approximately how it should have been looked/looked before 5.25.5:

1 Like

Well just for a quick test, hit the menu and call up ‘application style’.

Check the ‘GTK theme’ option - set it to Aidwaita-dark (should be a guaranteed success there) and see how it goes, then check the one you might wanna switch to. I can’t understand why it’s not following your colour scheme…

Having said that, mine uses the KDE picker, so it follows my colour scheme…
Using application style (Breeze, or Lightly - follows colour scheme)

Doesn’t seem to make any difference at all. For the reference, I’ve enabled such file dialog for KDE with this options in firefox’s about:config (through user.js)

user_pref("widget.use-xdg-desktop-portal", true);
user_pref("widget.use-xdg-desktop-portal.kde", true);
user_pref("GTK_USE_PORTAL", 0);
user_pref("widget.use-xdg-desktop-portal.file-picker", 1);

Hmmmm nothing else playing up?
New Firefox profile doing the same?
Mine’s right on the colour scheme.

I’m sure what you’ll see there is GTK - mine follows ‘Application Style’ set to Aidwata dark right now. (can’t spell that for TOFFEE).

Set widget.use-xdg-desktop-portal.file-picker back from 2 to 1 and bingo…

Good luck :wink: maybe delete Firefox profile, make it again, then sync.

Had the same thing this morning, xdg-desktop-portal-kde dumped core.
Restarting the service (and possibly browser, don’t remember exactly) fixed it for me:

$ systemctl --user restart plasma-xdg-desktop-portal-kde.service

And here comes the solution. Thanks!

Upd. Seems like I have to run this command each time the system starts. I tried to reinstall xdg-desktop-portal and xdg-desktop-portal-kde, but that didn’t help. Any way to workaround this?


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.