Plasma 5.23 unresponsive

I have recently updated my system

$ sudo pacman -Q plasma-desktop

outputs:

plasma-desktop 5.23.4-1

But, the system is extremely unresponsive.

If i reboot, it will show the plasma 25 years screen. Then the screen will go black with the mouse cursor remaining visible. Then after 5 -6 minutes, skype will appear. Then the desktop wall paper appears. But the desktop icons will not be rendered, neither would the taskbar appear. Right click has no response

So, i launch konsole via alt+f2. Then I do :

mkdir backup/backup
mv .config/kde* backup/backup/
mv .config/KDE* backup/backup/
mv .config/plasma* backup/backup/

Good. Now everything resets. I have taskbar, desktop icons, and right click context menu

I then adjust my task bar by

  1. Reduce the width from 44 px default to 32 px
  2. make taskbar autohide
  3. Drag taskbar to left edge of monitor (this step is optional i tested with and with out this step)

Then if i click on the application launcher / start menu - no response at all. Just the taskbar is now frozen in place. It does not autohide any more.

So I do :

killall plasmashell && kstart5 plasmashell

The result is :

Omitting both --window and --windowclass arguments is not recommended
kf.coreaddons: Expected JSON property “X-Plasma-ContainmentCategories” to be a string list. Treating it as a list with a single entry: “panel” org.manjaro.desktop.breathPanel
kf.plasma.quick: Applet preload policy set to 1
trying to show an empty dialog
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Desktop.qml:134:19: QML Loader: Binding loop detected for property “height”
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Desktop.qml:134:19: QML Loader: Binding loop detected for property “height”
Error: cannot change the containment to AppletsLayout
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:520:9: QML Label: Binding loop detected for property “height”
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:475:13: QML Label: Binding loop detected for property “height”
trying to show an empty dialog
file:///usr/share/plasma/plasmoids/org.kde.panel/contents/ui/main.qml:18:1: QML DropArea (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property “minimumWidth”
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:475:13: QML Label: Binding loop detected for property “height”
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:520:9: QML Label: Binding loop detected for property “height”
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:542:5: QML Label: Binding loop detected for property “height”
trying to show an empty dialog
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml:15:1: QML Panel: Binding loop detected for property “state”
libkcups: CUPS-Get-Printers last error: 0 successful-ok
libkcups: Create-Printer-Subscriptions last error: 0 successful-ok
libkcups: Get-Jobs last error: 0 successful-ok
libkcups: Get-Jobs last error: 0 successful-ok
Cyclic dependency detected between “file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml” and “file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationHeader.qml”
Plasma Shell startup completed
file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml:17:1: QML MouseArea (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property “minimumWidth”
Both point size and pixel size set. Using pixel size.
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/Tooltip.qml:54:9: QML GridLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property “minimumWidth”
Error: cannot change the containment to AppletsLayout
libkcups: 5 “Epson-Stylus-SX110”
libkcups: 5 “Stylus-SX100”
libkcups: 2
libkcups: 2
kf.i18n: “1 instead of 2 arguments to message {Drucken von %1 mit %…} supplied before conversion.”
kf.i18n: “1 instead of 2 arguments to message {Drucken von %1 mit %…} supplied before conversion.”

Now the silhouette of the task bar is visible like a transparentish outline. but the startbar doesn’t appear even after several minutes.

I have looked at this thread, but there’s no calendar in my system.

What is going on ? How can I solve it ? Result of uname - a :
Linux glassplanet 5.9.16-1-MANJARO #1 SMP PREEMPT Mon Dec 21 22:00:46 UTC 2020 x86_64 GNU/Linux

Thank you

May not be related to your problem but your kernel is very out-of-date and has not been supported for a long time. Try installing a newer kernel such as 5.10 (current LTS) or 5.15 (current stable, next LTS).

You could try resetting the plasma cache:

rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell
2 Likes

Resetting plasma did not work.

I am stuck with

(1/5) Arming ConditionNeedsUpdate…
(2/5) Updating module dependencies…
(3/5) Updating linux initcpios…
==> Building image from preset: /etc/mkinitcpio.d/linux514.preset: ‘default’
→ -k /boot/vmlinuz-5.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.14-x86_64.img
==> Starting build: 5.14.21-2-MANJARO
→ Running build hook: [base]
→ Running build hook: [udev]
→ Running build hook: [autodetect]
→ Running build hook: [modconf]
→ Running build hook: [block]
→ Running build hook: [keyboard]
→ Running build hook: [keymap]

when trying to install linux 514. It does not progress any more.

You’re trying to install another EOL kernel, install 5.10 (current LTS) or 5.15 (current stable, next LTS).

1 Like

Done. on 515 now.

Still the same issue.

I also created a new user, which does not have this problem.
I tried to copy .config/kde*,.config/KDE*, and .config/*plasma* files from that user to me, but the issue persists.

Please help

I seem to have resolved it.

killall plasmashell
rm -Rf .config/kde
rm -Rf .config/KDE
rm -Rf .config/plasma
rm -Rf .config/PLASMA
sudo pacman -Rnsdd plasma
sudo pacman -S plasma

logout, log back in has fixed it.

However, time to time,I will have to restart plasma and kwin. Other than that, its even a tad bit faster.

What was I doing wrong. I have used the nuclear option, and redone everything - but that’s not a very smart thing to do, is it ?

Thank you