Plasma 5.21 compositing and Firefox

Hi, folks!

Since the latest stable Manjaro update (OK, almost the latest, seeing as 2021-03-08 is out now), I am now enjoying Plasma 5.21—and, for the most part, I do enjoy it. Application menu is a little different, color theme is a little different, system monitors tick faster… none of these is “game-breaking” for me. :wink:

A major problem, however, appears to be related to the desktop effects compositor. Usually when I log in, I get the message “Desktop effects have been suspended by another application.” Using the Shift+Alt+F12 shortcut (twice) gets the effects (wobbly windows, desktop cube, non-Qt windows with transparent borders such as “Add/Remove Software”) working again. That, on its own, would be something I could live with for a few weeks, assuming it’s a known problem that will be fixed.

However, along with this came a worse problem: Firefox tab titles and certain things within tab content become garbled. This screenshot clip should illustrate my symptoms:

In order to read those tabs again, I must restart the compositor using the hotkey; I also have to refresh the page content because doing so causes the page to become blank.

So far (I updated two days ago) these are the only KDE problems I have found. Would anyone mind working with me to figure out what’s going on, and how to fix it?

Things I have already tried:

  • Restarting. I did this right after updating and the usual pacdiff, and again to see if it would help this problem, but it persists.
  • Changing rendering backend from OpenGL 3.1 to 2.0. This seemed to work for a couple of hours, but while I wasn’t watching the garbled tabs and graphics came back.

I am on a Ryzen system with AMD graphics. Further details:

inxi -F
System:    Host: kotoko Kernel: 5.4.100-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VII HERO v: Rev 1.xx serial: <superuser required> 
           UEFI: American Megatrends v: 2501 date: 07/12/2019 
CPU:       Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4 MiB 
           Speed: 4046 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 4046 2: 2036 3: 2035 4: 2341 5: 4076 6: 3567 7: 4005 
           8: 4049 9: 2033 10: 2515 11: 4064 12: 2282 13: 3780 14: 4062 15: 4055 16: 2040 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 2560x1440 
           OpenGL: renderer: Radeon RX 580 Series v: 4.6.13572 Core Profile Context 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Device-3: Sunplus Innovation Full HD webcam type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.4.100-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp4s0 state: down mac: 8a:3e:f3:06:ae:15 
           Device-2: Intel 82580 Gigabit Network driver: igb 
           IF: enp5s0f0 state: up speed: 1000 Mbps duplex: full mac: 00:1b:21:d3:86:20 
           Device-3: Intel 82580 Gigabit Network driver: igb 
           IF: enp5s0f1 state: up speed: 1000 Mbps duplex: full mac: 00:1b:21:d3:86:21 
           Device-4: Intel 82580 Gigabit Network driver: igb 
           IF: enp5s0f2 state: down mac: 00:1b:21:d3:86:22 
           Device-5: Intel 82580 Gigabit Network driver: igb 
           IF: enp5s0f3 state: down mac: 00:1b:21:d3:86:23 
           Device-6: Intel I211 Gigabit Network driver: igb 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: 04:d4:c4:4a:3c:57 
           IF-ID-1: br0 state: up speed: N/A duplex: N/A mac: 04:d4:c4:4a:3c:57 
           IF-ID-2: macvtap1 state: up speed: 1000 Mbps duplex: full mac: 52:54:00:db:ed:da 
RAID:      Device-1: datastore type: zfs status: ONLINE level: raidz1 size: 2.72 TiB free: 1.42 TiB 
           Components: Online: N/A 
Drives:    Local Storage: total: raw: 3.18 TiB usable: 5.9 TiB used: 1 TiB (17.0%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3X0C-00SJG0 size: 465.76 GiB 
           ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
           ID-3: /dev/sdb vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
           ID-4: /dev/sdc vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
Partition: ID-1: / size: 389.18 GiB used: 239.34 GiB (61.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 69.06 GiB used: 16.3 MiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 40.9 C mobo: N/A gpu: amdgpu temp: 49.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 789 
Info:      Processes: 533 Uptime: 1d 7h 39m Memory: 62.78 GiB used: 50.94 GiB (81.1%) Shell: Bash inxi: 3.3.01

Thank you very much for any assistance!

1 Like

could you try enabling the desktop effect that increases the contrast for windows in the background in the desktop-effect settings. i think its called background contrast in english. dont know for sure.
just activate it and then restart the compositor with the key combo shift+alt+f12

I dont know how, but this fixed a lot of crashes with the kde compositor for me.

OK, I have enabled that for testing purposes, although I don’t like it—it actually makes the Applications menu harder to read when it opens in front of a bright white window (like this forum). I’ll report back once I’ve had time to determine if it helps.

Nope, the problem persists.

Try System Settings ->Display and Monitor → Compositor: XRender as engine. At least it helped me a bit with nvidia and nouveau.

Thanks for the suggestion, and I will keep it in mind, but I may have made some progress. I made two changes at essentially the same time (so, yes, I don’t know which one was the fix):

Starting Firefox from the terminal, I noticed a raft of Gtk warnings related to missing theme files. That made me look at my Appearance settings and apply a new theme for Gtk 3.0 apps. (Materia-Manjaro-Dark if it matters.)

Also, I had been using export MOZ_X11_EGL=1 in my .profile, but I have commented that out for testing purposes. That line was added a few months ago, to get WebGL working. WebGL now seems to work without that, according to a test I did just now, so it would seem I don’t need that any longer.

I’ve been running for a couple of hours so far, and things are looking good. If the issue doesn’t recur in another 24 hours I will consider this solved. I am thinking it was probably the MOZ_X11_EGL but I’ll test by turning that back on to be sure.

I had thought this was solved, but after a reboot I went to watch a YouTube video and the graphics corruption instantly appeared.