Places Applet / Trash Applet: Broken links

Hello community,

I am new to Linux and I have fallen in love with Budgie.

For some time now (I can’t remember when it appeared) I have problems with the Places Applet and Trash Applet because the links are broken. A gedit window appears with a red banner ("/home/vespalino/Downloads« is a directory") instead of nautilus.

Do you have any ideas?

I don’t know if it matters, but in the past I have also tried Nemo but uninstalled it. I don’t remember if the applets worked proper before and after.

Thank you.

I found the solution in the Solus forum.

The reason didn’t belong to the Applets but to gedit.

I have deleted the line “inode/directory=org.gnome.gedit.desktop;” in mimeapps.list in .config directory in user directory, restarted the system and all is fine !!

This is weird…

After I have made the new update today celluloid made a new inode entry in mimeapps.list so that all links in places applet were opened by celluloid…

So I deleted once again the inode entry in mimeapps.list an it worked again.

Really weird…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.