Pipewire Problems need help

As of Gnome 4.2 i had to install/setup Pipewire and wireplumber, now my problem is that when playing Games i have audio samples not playing for a second or 2, E.G. a voice will cut off, the gun I’m shooting will have no sound, like i said for a second or 2.

USB Sound Card, UGreen Advanced Audio Device up to 32bit/96khz.

“pactl info” from terminal shows:

Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 120
Tile Size: 65472
User Name: *****
Host Name: manjaro
Server Name: PulseAudio (on PipeWire 0.3.51)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-C-Media_Electronics_Inc._USB_Advanced_Audio_Device-00.analog-stereo
Default Source: alsa_input.usb-C-Media_Electronics_Inc._USB_Advanced_Audio_Device-00.analog-stereo
Cookie: 4c7f:b049

Which looks right other then i can go to 96khz, but the problem i have is after looking at the forums for Pipewire problems and Arch Wiki support i cannot find most of the config files, the folders are empty (/etc/pipewire/client.conf.d/)
So does anyone know what/where are the config files i need to edit are located, and what i might edit to solve this problem, like drop to 24bit, maybe up or lower buffer?
Never had this problem before Pipewire/wireplumber, and also i am not running/installed easyeffects as i see no use for it.

Thank you if you can help me out.

check if pipewire-media-session is installed

No it’s not, but is’nt that replaced with wireplumber, but just seen this:

So should i drop wireplumber and install pipewire-media-session?

No you don’t (but you could try nonetheless), the “error” happened when you don’t have any audio device as far as I understood.

Thanks, i leave it for now.

Found the config files in “user/share/pipewire/” and most config files say to move them to “/etc/pipewire/pipewire-pulse.conf.d/” for system-wide changes, so I’ll try that and also try to figure out what i need to change/edit.

I have now tried everything i can, googled everything Pipewire, gone though every Doc i can find but for some really strange reason as soon as i move any config file from “usr/share/pipewire/” to the correct folder in “etc/piperwire/whatever folder needed/” and even if i don’t edit the config file and only copy it in to the right folder and then restart Pipewire services or reboot the computer i loose all audio, Gnome audio settings are blank, terminal commands error, etc, etc.

So I’m stuck with default settings (deleted all configs from “etc/pipewire/”), so problem with Games can not be fixed.

Did find i still had PulseAudio-Alsa installed and Arch Wiki says to remove it and use Pipewire-Alsa, which was already installed when i did Manjaro-Pipewire package, anyway removing PulseAudio-Alsa made zero differents.

for user works for me.

for global does not.

1 Like

I forgot to say that ~/.config/pipewire, etc, had the same problem, i would loose all audio if i copied the config file/files.

I’ve got it sorted now, some friendly Arch Linux user had the answers and fixed it in no time, so i am now able to edit a config file in etc/pipewire and don’t loose audio, the only changes i needed was:

default.clock.allowed-rates = [ 96000 88200 48000 44100 ]
default.clock.min-quantum = 32
default.clock.max-quantum = 8192

Still need to test as my problem can happen in a Game with in minutes to 30+ minutes, but so far sound in Games is working normal again.

Admin/Mods - This Topic can be closed now or Deleted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.