PinePhone with Manjaro missing details for setting in order to connect internet via SIM

Not sure how to start. I have a pinephone, which I wish to start using. i may connect to internet via wifi. But I cannot connect to internet with SIM card. i cannot enter anywere information like MMC or MNC, which I think is essential to estabilish the connection, and also the whole setting api for adjusting SIM connection is having too little parameters. I guess, I need an update for EU standard settings. Ma somebody recommend what todo?

Plasma Mobile is in heavy development, but somehow now is at slower pase. If you want to use your PinePhone more closer to what is suppose to be a daily driver, switch to Phosh, flash it either to an SD card or internal.

You can get the latest releases from here:

Avoid Plasma Mobile Dev for now.

Plasma Mobile has the ability to autodetect APN information.
Can be found in Settings → Cellular Network → SIM → Modify APN

1 Like

Thank you for feedback, I wish in a first place to use phone for now only for Telegram especially at some places, instead of my old Samsung. I understand that it may be some differencies. the problem I find is that I am not even recieving sms, for activating and account. (maybe it does have sth, to do with network settings). Is there a way how I can figure out If I am actually installed KDE plasma or sth else?

Mayby I am having some older version, because I DO NOT have cellular setting in my phone, I have only Mobile and it is not available when no SIM inserted.

It even look quite strange as I feel that the messages are not being recieved sometimes, or they come with huge delay

Are you sure it has Plasma Mobile on it?

If it is, it should have a Cellular Network entry in Settings if you are up to date.
Check with sudo pacman -Syu in the terminal app.

Ok, Sorry, I do not remember what was my root password now. Have to search for it, or there are some default ones?

Plasma Mobile only has the passwords you give it during setup.

This mobile came preinstalled. I do not remember seting on it anything up

So you bought it used. Then you likely need to re-install, by downloading a new image from our website and an SD card.

Sorry, I am just in such a blackout. I bought community edition it new, but, I do not remembeer the password setting. It was already about 2 years back, so Maybe I should really reinstall it.

Do you mind give me link how to do it? DOyou recommend he KDE plasma or that Phosh?

You can find it at Manjaro Downloads → Manjaro ARM Team → Pinephone

I’m a Plasma guy myself, so I am biased.

I tried, I got password, probably still the default one. The problem is that the message i get is:
error: Failed to update Extra(unable to lock database)
error:Failed to update community(unable to lock database)
error:Failed to synchronize all databases

You seem pretty new to this.

Pacman would have given you instructions on how to get rid of that error.

sudo rm /var/lib/pacman/db.lck
sudo pacman -Syyu

I am glad for feedback, any help. I got a bit disconnected from IT for years now I wish to come back, and do something . I tired the rm command and got back that: cannot remove ‘lck’ file file not exist.

Is there some nice new manual that helps for firsttimer to update the phone or reinstall easily please?

I used nemo, and tried to search for that file in root and it is there though.i will try to change owners right it look it says root does not have owner rights.

I tried inxi -S and find out following: Setting locale failed. Not sure what means that.
Than: failing back to standard locale
kernel: 5.9.14-manjaro-arm aarch 64
bits:64 Desktop:Gnome
Distro: manjaro-arm

I tried sudo chmod u+rw /var/lib/pacma/db.lck -R
still say as if file does not exist – but got removed it by command pacman force-update…
NOW I run pacman -Syyu, and wish, hope to continue form here.
I am running update now, and ended at some list of updates, at one point it say somethinc conflitct with ‘phoc’

What is phoc, do you or somebody knows?

I have pinephone community edition about 2 years old. It says it runs gnome desktop, not sure what it means.
kernel: 5.9.14-manjaro-arm aarch 64
bits:64 Desktop:Gnome
Distro: manjaro-arm

pacman update
it did disable a a bunch of keys and then signed a bunch of local keys…
Do you can explain if that is something to be worried abou?

then it asked:
replace xorg-server-xwayland with extra/xorg-xwayland? y/n I said n
but then it says: warning removing wlroots from targetlist because it is in conflict with ‘phoc’

somebody knows what it means please?

If you still have the factory image from 2 years ago, then trying to update now will be a pain, and you might not succeed after all.
Better, as mentioned before, flash a new image from the links provided.
Instructions on how to do it are here PinePhone Installation Instructions - PINE64

I’m using now the Beta12 image and i can’t enable mobile data. What version are you using and on what branch? Thanks.
The slider in Cellular Networks Settings jumps back, and from drop-down Notifications does nothing when i click on it.

Thank you, I tried the update of Pacman, did not do anything, nor install, despite all the process seemed going Ok, it ended on asking for removing and invalid chcecksum ring, that I approved.

Ok, i am upto reinstall it if necesarry. Maybe I wish to hear from somebody if there is a difference in community version of installed linux (that I had 2 years ago) {as I remember correctly something like that it was more lightweight version of Linux than mobile versin} and Linux plasma mobile version of linux so that I may choose which new system to install.

thanks for feedback

Since 2 years ago a lot of things changed, regardless who released the images and if is Plasma Mobile or Phosh.

I can enable it on both Dev images and updated Beta 12 images. But it requires me to activate an APN first.

i tried chmod +x /dev/mmcblk2
I am at the last step to transfer sd card working image to eMMC by
dd if=IMAGE.img of=/dev/**mmcblk2 bs=1M status=progress conv=fsync

getting response :failed to open permision denied to /dev/mmcblk2
is there a way how I could add owner rights to dev please?