Pinephone volume buttons not working

I recently got my pinephone manjaro community edition, and it’s amazing. I flashed the plasma image on it and it seems to be working very well. While there are issues such as the browser (angelfish) crashes when you do pretty much anything, but that happens on my laptop too and I expect it to have a few bugs. The main topic of this post is about the volume buttons, which work sometimes. It’s very rare but it occasionally works as intended, other times I press it and nothing happens. I can still change the volume from settings but other than that it is broken. I noticed on the post where I got my ISO it said the volume buttons worked, so I just want to ask is anyone else experiencing this issue?

My volume buttons are working on Manjaro, but I have noticed that Phosh does not pop anything up on-screen when I use them. If you’re looking for something like the overlay that comes up on iOS, maybe Plasma has it, Phosh does not.

That said, I believe you that you’ve checked after pressing them =P

Is this just on Plasma, or did you have the same issue using Phosh?

I haven’t tried phosh, but yes the plasma version does have a popup which looks identical to the desktop version. I have carefully watched the volume status in settings when it appears to be not working and there is no change.

Hi !

Maybe there’s no point writing this but do you stay ‘put’ pushing waiting the volume go down or up or do you push one time, then again, and again for each time you go down or up?

I have tried both with no success.

You might have a problem with this : PINEPHONE SIDE KEYS FLEX PCB – PINE STORE or PINEPHONE BACK COVER – PINE STORE

Did you try removing the back cover and pushing the button up or down ? (Don’t do a long press, only simple press would work. I mean you have to press one time for each time you want to go down or up)

I’m sure it’s not a hardware problem, the buttons click just fine with or without the back cover. And yes, I usually just press the buttons once but I tried for the sake of trying doing it the other way.

Can you please give more information on the image you flashed? Which version? Stable, unstable? etc?

Seems you’re the only one experiencing this problem after looking at : Issues · manjaro-arm / issues / Pinephone / Plasma-Mobile · GitLab

@philm I think you would know better than me :roll_eyes:

I’m using the unstable image with plasma-git packages, I got the image from here and flashed it to my emmc using jumpdrive.

While I have not tried Plasma yet*, I had similar concerns regarding the volume buttons on phosh. There I noticed I could open settings -> sound to see a volume bar which would move when I pushed the volume buttons. That put my heart at ease. :slightly_smiling_face:

*I only received my Pinephone on Friday and, in fact, this is my very first posting to this forum. So, please be gentle. :wink:

This issue was fixed (at least for me) in a recent update