Pinephone -Trouble upgrading

:: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade…
:: Replace xorg-server-xwayland with extra/xorg-xwayland? [Y/n] n
resolving dependencies…
looking for conflicting packages…
warning: removing ‘gtk3’ from target list because it conflicts with ‘gtk3-mobile’
:: xorg-xwayland and xorg-server-xwayland are in conflict. Remove xorg-server-xwayland? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘gtk3>=3.22’ required by pamac-gtk

:: Replace xorg-server-xwayland with extra/xorg-xwayland? [Y/n]

Answer here must be yes i think. Use console version if pamac-gtk chooses this for you.

: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade…
:: Replace xorg-server-xwayland with extra/xorg-xwayland? [Y/n] Y
resolving dependencies…
looking for conflicting packages…
warning: removing ‘gtk3’ from target list because it conflicts with ‘gtk3-mobile’
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘gtk3>=3.22’ required by pamac-gtk
[manjaro@manjaro-arm ~]$

Remove pamac-gtk. Then do the update, and re-install pamac-gtk.

Thank you. The update went fine