Pinephone - No phone calls

Hi there!

I’m very glad to at last have my Pinephone!! I’m very happy and I’m enjoying it a lot!

Yesterday I had one problem; I have been using my Pinephone without SIM card, but yesterday finally I got one. Once I installed, the Pinephone recognised the SIM card, and ask me for the PIN. Once the phone was open I did not have signal of any type in the Pinephone. I tried with different SIM cards from other providers with the same result.

Today I installed PmOS in order to try if it was something due to the OS, but the result had been the same. I went to the terminal and the output of the uname -r was 5.9.1-9-MANJARO-ARM.

At the end, I bought 2 pinephones (for a colleague), so I used the second one with the SIM card and it worked without any issues! So I did uname -r and the output was 5.9.1-4-MANJARO-ARM, because it had not been updated. It could be due to this difference that I can not make phone calls with my pinephone? Does anyone know something about it?

Thanks very much for your time and attention!

See you around! And keep the great work!


did you update the PinePhone? (you can update by plugging it with Ethernet to your box, might need a reboot)
did you lock down the ‘1’ on the back of the PinePhone?
did you activate the WWAN Adapter in the PinePhone? (Top Menu, first icon : ‘Cellular’)

Maybe it would help you. Otherwise maybe the PinePhone doesn’t have the required signal for your SIM card, I read that some SIM card doesn’t work with the PinePhone…

* Worldwide, Global LTE bands
* LTE-FDD: B1/ B2/ B3/ B4/ B5/ B7/ B8/ B12/ B13/ B18/ B19/ B20/ B25/ B26/ B28
* LTE-TDD: B38/ B39/ B40/ B41
* WCDMA: B1/ B2/ B4/ B5/ B6/ B8/ B19
* GSM: 850/900/1800/1900MHz


Yes, I updated the PinePhone via terminal and wifi.

All the switches in the back of the phone are ON, and the WWAN was activated once I installed the SIM card.

I thought that, but I tested the SIM card into another Pinephone and worked without any problem…

You may want to test with the factory image once more. I’ve to check again what changed between 5.9.1-4-MANJARO-ARM and 5.9.1-9-MANJARO-ARM. You can also try with the latest version of the available images using the Megi kernel: Downloading File /pinephone/phosh/beta2-20201112 - Manjaro ARM - OSDN

I might release another image this weekend with some fixes …


I’ll check this and I’ll be around to try the new release! Thanks!

I checked both images and it’s the same, so I assume that it has nothing to be with the OS. Because the factory image was at 5.9.1-4-MANJARO-ARM and I have the same problem with the SIM card.

Thanks for the help!