PinePhone convergence connector usage

I got my PinePhone Convergence order recently and found a few bumps in the road.

I wanted to test the convergence connector, but no ethernet and HDMI resulted in black screens (both hdmi and phone).

To get “ifconfig” up, I had to “pacman -Syu net-tools”

To get pacman to update, I had to choose “upower-mobile” over “upower” to resolve the conflict. AOK after that.

The problem with the convergence connector is related to having it plugged into power. With the (red) power connector disconnected, I got both eth0/Ethernet and my HDMI display working (also with USB wireless keyboard & mouse).

I was also able to install the OpenSmalltalk VM and run Cuis Smalltalk.

So, some bumps, but pretty much able to muddle through so far.

FYI,
-KenD [ken (do) dickey (at) whidbey (dor) com]

2 Likes

I think linux in general is moving away from ifconfig. To get the same ip address you can use “ip address”
or “ip addr” as like to do.

I had no issue with the connector plugged in with power and data. I haven’t tried hdmi yet

2 Likes

Hi!

Did you try to plug the PinePhone with the adapter, the Ethernet, then reboot the PinePhone?

Please charge the phone fully and only use the dock without the power supply plugged in. When it is connected to power it uses too much mAh and attached devices don’t function anymore. If you use sysfs to lower the input current to 900mA it will enable again …

Hi all,
new user here, got my CE phone last week :slight_smile:

I write this reply after connecting the CE adapter first time. All worked plug&play (keyboard/mouse/HDMI/Ethernet) right away (no reboot needed). Super!!

Is this still true? In my case here, before I used the dock, I checked the current input limit a couple of times:

  1. on charger 1500
  2. same charger plugged into dock, then the dock into phone: 500
  3. same as (2.) but plugging keyboard/mouse/ethernet/HDMI: still 500
    This reads safe, not?

To me this behaviour would make sense, if the kernel recognises the dock as a USB-port (not a charger), limiting the current limit according to the charging described: by xnux here
What do you think? Still necessary to limit current_max ?

edit:

(Sorry, I did not want to hijack your thread.) One thought I had reading your issue was that maybe the wireless dongle for the keyboard/mouse drags extra current, exceeding the current input limit on the dock. You could try if behaviour stays the same with simple wired devices.