Pinebook Pro won't boot after flashing to eMMC

Hello all,

I recently tried to reflash my Pinebook Pro to the latest Manjaro install, specifically 22.10, the KDE Plasma edition. I did this by booting the generic image from an SD card, and then using the manjaro-arm-flasher tool to flash the eMMC module.

During that process, I picked the generic image, and not the pinebook pro image. It wasn’t until later that I read a forum post mentioning something about having Tow-boot on SPI in order for the generic image to work. I saw no mention of this when I downloaded the generic image (which booted just fine from SD) from the website, so I figured flashing the generic image again would boot just fine…

Regardless, it appears that I was wrong.

But now I have a black brick. The only lights that come on are the red power light that appears when the power cable is plugged in.

I’ve tried resetting the device, holding the power button over 60 seconds. I’ve opened the back and hit the reset button. I’ve hit the recovery button as well (as mentioned in a post on the Pinebook Pro forums). I’ve disabled the eMMC using the internal switch and hit all of the resets again. No lights turn on to indicate any kind of booting at all. No orange, no red, nothing.

I have the same SD card in the laptop that I used to do the initial flashing, so I know that’s good.

Any tips or tricks to help me unbrick this thing and boot properly from an SD card again so I can do a (hopefully better) flash to the eMMC and wipe my hands of this issue?

Thanks for reporting this. The notes where previously displayed to show this information, but seems it’s no longer the case with the new layout. Created an issue on our webpage repo for that.

While this should work with booting images from SD card that provides it’s own u-boot, the SD card you have with the Generic image, does not. So the system has no idea what to boot, as there’s no board firmware present anywhere.

So you have 2 options for fixing this.

  1. Download the latest Tow-Boot for your device. Extract it and flash the spi.installer.img file found in it to your SD card. Enable the eMMC again, plug in the SD card and it should boot into the Tow-Boot installer where you can flash the firmware to the SPI. When it’s done, reboot and it should boot into your eMMC Manjaro install.

  2. Use the Manjaro ARM Installer script, to create an install of Manjaro on your SD card, choosing “Pinebook Pro” as target device. This will create an install with the Pinebook Pro specific u-boot, which will then boot and you can do the same from the SD card to your eMMC when you boot from that SD installation.

I would recommend doing the first one, as it takes less time and is compatible with more OS options you might wish to try in the future.

1 Like

Thank you for your quick response! I’ll give that a shot and report back.

Okay I tried option 1, using Tow-Boot, but it never seemed to boot properly. I had no output on my screen, and the booting lights never got past orange. It went from red to orange, but then stayed there with no screen output.

So I tried option 2, using the Manjaro Installer script.

I was able to get it to boot the SD card properly, and it eventually ended up on a green light, but my screen is still black.

So I’m a bit further along, but haven’t gotten any display output at all with either option.

The screen was working just fine before my unfortunate flash a few days ago. Not sure if my screen connector got damaged somehow or what.

I think the only option left is to try using an usb-c to Displayport connector to see if that boots. I’ll give that a try tomorrow.

Sounds like you might have disconnected the LCD cable when switching on/off the eMMC. It’s very fragile. So please check if that connector is probably inserted.

USB-C Display is not gonna work, as it’s not supported in the mainline kernel at all.

I made the exact same mistake and I solved it by reflashing the eMMC (as suggested by @Strit) by using the Pine64 eMMC-to-USB connector and the support of another computer (as the PBP in that state is unusable).

Okay, I got everything working!

Strit was correct, the latch that held my LCD cable in place was lifted up after I removed the tape to pull up the shield over the SPI. I’ve never worked with LCD cables before so I didn’t notice. But after pressing the latch down on the ribbon/cable again, the display lit right up.

I was actually able to complete option 1 properly this time with a working display, and the initial generic flash that I did to the eMMC worked like a charm after installing Tow-Boot to the SPI.

Everything’s now working as expected, much thanks to @Strit for the help on this one.

Edit: And yeah, I was considering the USB-to-eMMC approach, but I don’t have an adapter like that on hand at this time. Luckily I was able to resolve it all without it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.