Pinebook Pro WiFi not working after update


I’ve run pamac upgrade this evening and now my WiFi isn’t working on my pinebook pro :frowning: which is awkward as I’m going away tomorrow morning, and I’d really like it to bring a working laptop with me!

relevant information (typed, I can’t post this from my laptop without wifi):

uname -r

journalctl shows some errors from iwd, specifically:

And then “iwd.service: Main process exited”

So I guess my problem is a kernel upgrade gone wrong? I’ll try to download an older kernel and copy it over via SD card to start with.

This kernel is out of date.

If you can, boot the laptop, connect it to internet via ethernet or mobile.
Then make sure your /boot partition is mounted with lsblk.
If it is, please update the system with sudo pacman -Syu, so you get 6.0.7.

Hi, thanks for helping!

I am unable to get the laptop connected to the 'net.

It’s very odd, if I run pacman -Q linux I get “linux 6.0.7-2”
and if I run uname -r I get “6.0.2-3-MANJARO-ARM”

which seems like different versions to me. I don’t know what’s going on here, or why this would be the case.

I’m not sure about mounting my boot partition; I’m running using LUKS disk encryption, so my root partition has a /boot folder with stuff in it. I think this is ok?

actually it might not be ok at all, checking compared to my desktop. I’ll try mounting the boot partition at /boot and reinstalling the Linux package from the pacman cache.

1 Like

OK that did it! Thanks for the clue @Strit !


  • pinebook pro originally installed manjaro-arm via manjaro-arm-installer, using crypt option for full disk encryption
  • WiFi on pinebook pro stopped working after a pamac upgrade,
  • running linux kernel version as shown by uname -r was outdated, but installed linux package was up-to-date.
  • for some reason my boot partition isn’t mounted by default at /boot. I don’t know why this is, and I don’t know if it ever has been mounted at /boot. Need to figure this out (and fix properly)

ran as root:

mount /dev/mmcblk2p1 /boot
cd /var/cache/pacman/pkg
pacman -U linux<version>.pkg.tar.zst

and it seems to be workin again.

This was a bug we had in the installer a while back! So sorry about that. We have since fixed that bug though.

1 Like

Ah ok thanks! I guess I should just add the entry to my /etc/fstab file to fix permanently?

Yes. That’s what our installer failed to do back then.

1 Like

Nevermind, I found the solution searching more after I posted. I just need to cold boot the machine, not restart as discussed here (I can’t include links in my post). Apologies! Hopefully, this updated post will help others struggling with search like me.

1 Like