Pinebook Pro PBP Vault crashes during creation Error 9

Hi,
I am working on a Pinebook Pro with Manjaro 20.2.1

I tried to create a Vault with CryFS but unfortunately the creation results in an error:
Unable to perform the operation (error code 9).

some logs from the journalctl

Mär 25 18:54:45 pine kernel: oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/session-c2.scope,task=cryfs,pid=13521,uid=1000
Mär 25 18:54:45 pine kernel: Out of memory: Killed process 13521 (cryfs) total-vm:3611004kB, anon-rss:2410952kB, file-rss:0kB, shmem-rss:0kB, UID:1000 pgtables:4880kB oom_score_adj:0

Regards

Seems it's a general Plasma 5.18 bug, not just ARM releated:

Just tested on my Plasma 5.18 on my Pinebook Pro.

Worked fine here.

Make sure you have the
CryFS package installed, before trying.

Hi @Strit thanks for reminding me for the obvious :slight_smile: Works after installing cryfs and a restart.

Is there a way to remove Zombie entries - I deleted the directories in ~/Vault/ and .local/share/plasma-vaults but after a restart the entries keep appearing as Zombies

I delete mine from the plasmoid settings for the share.

Hi @Strit
after after reboot cryfs sometimes works but after working a bit I get


Mär 29 18:30:10 pine kernel: oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_m>
Mär 29 18:30:10 pine kernel: Out of memory: Killed process 6360 (cryfs) total-vm:3611012kB, anon-rss:2658720kB, file-rss:4>
Mär 29 18:30:10 pine kernel: oom_reaper: reaped process 6360 (cryfs), now anon-rss:4kB, file-rss:0kB, shmem-rss:0kB
Mär 29 18:30:10 pine kded5[1227]: OUT:  "CryFS Version 0.10.2\n\n\nGenerating secure encryption key. This can take some ti>
Mär 29 18:30:10 pine kded5[1227]: ERR:  ""

same happens if I use cryfs on command line

also documented at https://github.com/cryfs/cryfs/issues/335

Forum kindly sponsored by