Pinebook pro freezes after some USB-C data transfer kernel 5.5.0-0.1

Pinebook pro with Manjaro XFCE. The system is up to date as of posting. Rebooted, several times. Tried this over the last few days a few times, the problem persists.

  • What package contains the bug?
    I'm suspecting linux-pinebookpro 5.5.0-0.1

  • Describe the bug the best you can. What where you doing when the bug happened?

My USB-C hub causes the laptop become unresponsive when I try to use any of the features of the hub for a longer time. E.g. if I connect something that transmits a low amount of data (presenter, gamepad) to the USB 3 then it works for some time. After a few successful transmissions Pinebook becomes unresponsive. If I try to mount an SD connected to the hub, that freezes the pinebook instantly. No matter which device I use on the hub, it's always the same with the 5.5.0-0.1 kernel.

Only long pressing the power button works to kill the laptop.

Tried it with power connected, disconnected, powered through the USB hub, same problem. It looks like something is messed up after a few transmissions over USB-C.

The hub is detected, I can run the following on both kernels, giving the exact same output (just showing the 5.5). The hub is disconnected first and then connected, just to show what hardware is detected on the hub if this helps.

lsusb > `uname -r`-NoHub
lsusb > `uname -r`-Hub
diff 5.5.0-0.1-MANJARO-ARM-NoHub 5.5.0-0.1-MANJARO-ARM-Hub 
2a3,4
> Bus 008 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
> Bus 008 Device 002: ID 05e3:0626 Genesys Logic, Inc. USB3.1 Hub
3a6,8
> Bus 007 Device 004: ID 05e3:0751 Genesys Logic, Inc. microSD Card Reader
> Bus 007 Device 003: ID 214b:7250 GenesysLogic USB2.1 Hub
> Bus 007 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
  • Any workarounds or known fixes?
    Reverting to linux-pinebookpro 5.4.0-2 solves the issue, USB-C comms is stable again, no freezes.

version 5.5 is Release-Candidate ( RC) that mean not STABLE

Thanks, I was under the impression that I'm running stable only. This kernel showed up as an update with the rest, now I blocked it.

It's actually very possible that it's related to uboot instead.

The other devices we have, that use the same uboot (Rock Pi 4 and RockPro64) has the same issue when transferring over 2 GB of data over the SoC bus.
It's believed that the issue is caused by the Rocjchip Blobs in the uboot we use.

I have been trying to build a uboot without these blobs, but that requires ATF, which we have issues building, so I have had no luck with it yet.

But it is something we are working on.

1 Like

Thanks a lot for the answer and good luck building the firmware.

Forum kindly sponsored by