Pictures and helper in Konsole

I have updated Konsole and now it has pictures. Thats not the main problem. My alias from ~.bashrc does not work. It say: command not found.

Is there anyway I can revert back to the old text-only based Konsole?

welcome!

it would be help if you can upload a screenshot of your problem on imgur.com and give a link here :smiley:

Hi @anox, and welcome!

AFAIK KDE, thus Konsole no longer uses bash but has switched to zsh. So any aliases and so on need to be in ~/.zshrc. Well, I think this could also be the cause of the changed shell. It is a zsh theme, caalled powerlevel10k.

KDE is a desktop environment … it doesnt really have a ‘default shell’ … maybe you mean Neon, which is KDE’s development distro … but I dont think they use zsh either?
In any case, thats something configurable by distro ISO/packaging/configuration … and in the case of Manjaro, zsh is used as the default by all the main editions now.

But if OP is saying they were using Bash, and an update switched them to zsh somehow without their consent … I would be interested to know how.

(I use bash as well … and have never been forced to change by any update)

@anox if that is the case, you can find the logs in /var/log/pacman.log … please share the last update transactions here (or preferably on a pastebin linked here) .

Definitely not.

Well, I don’t know what else to call it, then. Please tell me, because then I’ve learnt something new.

:partying_face: so not completely wrong.

Thank you for all the reply’s :slight_smile:

I was a little fast, but very frustrated. I found out that after the system update, there is something called Search. It is found under: Settings > Config konsole > Tab: General
Search:
Highligt all matches
Search backwards

They where checked. After I did unchecked them, it went back to normal text-only. Maybe I’m old school, but I like it that way :smiley:

…is…is that actually the solution?

I thought we were talking about your shell changing (for example your bashrc not functioning).
“Search Highlight” setting is not related to which shell is in use … for example I have those settings enabled, and have for years, and dont have any ‘pictures in konsole’.

I tried to turn the function on again, but seems you are right that was not the solution. Any idea what I might have turned of to remove the pictures and error detection/helper? nzb is a alias for ssh into my server. :slight_smile:

How do I upload a picture to this post?
Sorry, you can’t embed media items in a post.

Please return the following;

echo "$SHELL"

Also … as noted above … I would like to see how/why you ended up where you are now (with zsh if I am correct).

grep -iE 'zsh|bash' -n3 /var/log/pacman.log | tail -n60
echo "$SHELL"
/bin/bash
grep -iE 'zsh|bash' -n3 /var/log/pacman.log | tail 60
tail: cannot open '60' for reading: No such file or directory

imgur. com/a/wujtwTN

oops. typo.

grep -iE 'zsh|bash' -n3 /var/log/pacman.log | tail -n60

But …

Oh. That says you are using bash.

But …

This very much shows zsh…

Strange :thinking:

EDIT:
Oh. I get it. $SHELL variable is only changed from Login.
You can try instead to show:

echo "$0"

To change konsole back to bash, click Settings, Edit Current Profile… and change Command: from /bin/zsh to /bin/bash

EDIT: Or just emabrace zsh and add your alias to ~.zshrc

I’m not sure, how I was able to change to /bin/zsh. It happen after I updated the system, but I don’t think it was that. Maybe I have switched between profiles or somehow reverted back to a default.

I do not know what /bin/zsh is, I have always used bash. But I’m learning every day in Linux.

Thank you for your help :smiley:

It’s similar to bash. Only more modern…to put it that way. All, or most at least, of the bash functionality can be found in zsh.

Or that’s how I understand and have it, anyway.

It’s because the used shell is set in the Konsole profiles, and due to the way @LordTermor packaged things, the Breath profile became read-only to regular user accounts. So the solution was to create a new profile and set its shell to bash in that.

I’m not sure whether things have been fixed in the meantime, but they are supposed to have been.


Actually, not quite. zsh is not a POSIX-compatible shell, while bash is. zsh also appears to have taken more inspiration from the Korn Shell, and it behaves very differently.

The reason why it’s more popular these days is because of those graphics. It’s eye-candy, and the newbies want it simply because it looks cool, without understanding what it is.

It was a bad decision to make it the default, in my humble opinion. Besides, the system still uses bash for most things. It’s only the interactive shell that has been switched to zsh. And that makes it even more of a silly decision.

:man_shrugging:

2 Likes

I almost mentioned chsh … then … nah. :sweat_smile:

That is why I said “similar”. I know not everyone’s a fan. I mean I’m an air conditioner, not a fan.

:wink:

2 Likes

Also @cscs

It’s intended. I can’t make it proper without breaking current configurations. People were using default profile and now default profile uses zsh. Nothing much I can do here without getting rid of zsh completely.

1 Like