Picom or Compton not working

So i’m using manjaro with the qtile WM, and everything is working fine except for when I try setting a compositor. At first when i ran it from dmenu it would start fine until i restarted ofcourse, so i created a .sh script assosiated with the qtile config file, and from that time I don’t seem to be able to get the compositor running, even when trying to run it from the command line.
Here is the .sh script:

pidgin &
dropbox start &
picom &

The Qtile config.py script:

def autostart():

Do the other two programs start correctly?

Can you start picom from the terminal?

My command to start picom is:

picom \
   --daemon \
   --experimental-backends \
   --backend glx \
   --config ~/.config/picom.conf

(So with additional arguments like the path to the config file.)

Just a guess…try using it with -b argument as I do in my dwm install:

# start compositor
picom -b &
picom -h

  Daemonize process.

Do the other two programs start correctly?

I don’t really know… I didn’t even put them there tbh.

Can you start picom from the terminal?

When I type “picom” in the terminal it seems like it starts fine, i guess. I hit enter and I get no errors, but when i try searching for it in htop it don’t see it.

My command to start picom is:

I did try your script. Still nothing. I haven’t changed the config file of picom at all. Im pretty sure im doing something wrong here…

I have also tried that with no luck :frowning:

Is your script executable? If not then make it executable and try running it from the terminal:

chmod +x ./path_to_script
./path_to_script &

I believe it already was, but i did it anyway.
I ran the script and i still don’t see picom running.

What exactly happens if you start picom from the terminal?

I’m posting a screenshot because i don’t know how to explain it.

Excuse the name too!

Did you figure anything out by the screenshot?

So, I guess it’s running. However, probably you need a config file or some kind of configuration.

Is there something in the journal? Open two terminals, run journalctl -f in the one and picom in the other. Maybe there is something logged.

Or it might be in a file ~/.Xsession-errors (or similarily named), or in /var/log/Xorg.0.log.