Picom not respecting config

I just booted into and updated a system I haven’t been using for a while, one of the first things I noticed after updating is that my compositor is acting up, turns out compton got renamed to picom, my .compton.conf also got renamed to .picom.conf.

This wouldn’t be a big deal, except picom is not respecting the settings of .picom.conf. One particular setting I want to disable is fading, so I set

fading = false

But it does not work, fading in/out still happens when I open/close/minimize/restore windows.

I’ve tried using commandline arguments for instance

picom --fading=false

It accepts the argument, but doesn’t actually do anything (e.g. picom doesn’t run with the setting enabled after I run the command, which is just downright odd behavior)

Is the compositor just broken or is the config file $HOME/.picom.conf an incorrect filename/location or what, what is going on?

(I know my config file is not of incorrect syntax or anything, it’s my original compton.conf that worked fine and the syntax and args haven’t been changed, additionally I also tried replacing it with the example config from /etc/xdg but it does not read that any better)

That is a long time ago.

Use ~/.config/picom/picom.conf

remove all other reference to either picom.conf or compton.conf

Copy the default from /etc/xdg/picom.conf to your local .config/picom/ folder and modify as needed.

1 Like

Thank you, it is odd, if the config path was changed from $HOME/.compton.conf to $HOME/.config/picom.conf

Why is it that my ~/.compton.conf got renamed to ~/.picom.conf instead of ~/.config/picom.conf?

1 Like