Pi 4 sway error

Hello guys

I just downloaded the latest Sway version for the Pi 4 8GB, flashed with etcher and booted the Pi.
I get an error “Missing a required Wayland interface”, and it is stuck there.

Any help would be highly appreciated


no such error here, try again with dd.

Did you hashed the image?

Thanks, just did, it matches. I will try to flash it with dd, but that should not be an issue…

Thanks again

If possible, try rpi-imager, which could be installed by pamac.

Thanks I tried, no luck. I even tried with another Pi, just in case it was a hardware issue, but I get the same error. I guess I will go with Manjaro mInimal and then install Sway manually. Kinda wanted to not do that, but it is what it is.

Thanks again!

try another Pi not another sdcard?

The GUI will take a little while to load on first boot, since it’s in process of resizing the SD card, autologin the OEM user and starting Calamares.

How long have you tried waiting?

Alright, I figured what was happening, the error was a bit misleading. I connected the keyboard directly, without the hub I normally use, that did the trick. So that was the missing wayland interface…

Thanks, hope this helps other people that tries to boot the Pi without a valid keyboard…

1 Like

What is “pamac”?

It’s a package manager made by Manjaro.


So, what is the solution it works if you want to run without the keyboard plugged in?