Pi 4 / 64 bit / Youtube slow


I am new to Manjaro and am trying it now on a Pi4. (overclocked it). The only thing that i haven’t fixed yet is A SLOW YOUTUBE. (which seems to be a driver/64bit problem, right?)

What do i need to know about Manjaro in order to experiment with the Pi4? How do i change repositories? (stable/testing) How do i change kernel(s) ?

Thanks for answering!

Greetz: Patrick

ps: sorry for being lazy :slight_smile: sudo pacman-mirrors --api --set-branch {branch}

Mainly, you have a choice of 3 kernels: linux-rpi4, linux-rpi4-mainline and linux-rpi4-rc. Currently, linux-rpi4 is the better choice as both the mainline and rc kernels are currently being held up as the RPi Foundation transitions to the 5.10 kernel.

I am able to watch youtube video without issues, so with the right configuration for your setup, you should be able to also. I use KDE Plasma and it runs very well in both X11 and Wayland. Ideally you will probably want hardware video acceleration, so you want glxinfo to show the renderer as “V3D 4.2”.

1 Like

Hi, I experience the same lags playing Youtube in a web browser (chromium or firefox, even with HW arcceleration enabled).
How can I check if I have the right Kernel ? If not, how to change ?


I don’t have any experience with the Pi4 (yet), but I have the best results with Chromium that uses the VideoDecodeAccelerator.
Check if hardware video decode is on in chrome://flags and search for hardware-accelerated video decode
That was with an Intel N5000 with Pop!_OS, but I guess it should be similar with Manjaro on ARM.

So I guess it’s kernel, proper browser build and hardware video decoder activated.

I forgot to mention that you can check the video decoder in use somewhere in the Developer Tools menus in Chromium, when you play a video in Youtube.

Hi, thx for your answer!
Well, the HW videos decode is indeed activated in chromium.
By the way I’m running the OS from a SSD so it should be quick.
That issue is only happening when playing 1080 videos but it worked all right in Mate 64 on the same Pi4 (8GO), just sad that it does not work Manjaro, I love this distro I’ve just discovered. Too bad.

I wonder if I should enable vulkan also?

An update on the status of Vulkan support.

1 Like

Mate use compton as compositor with an adequate config. Try to disable the xfce compositor first. It was the culprit for me, and use compton. F11 to switch fullscreen may help. And use an extension to limit 60fps to 720p.

That flag is still no guarantee that Chromium is using hardware video acceleration.
It only says it will try to do it.

When you are playing a YouTube video in Chromium, hit CTRL+SHIFT+I and it will open the Developer Tools, probably with the Media tab (otherwise find that tab) and click on player. There you will actually see which decoder is in use and if it is using hardware video decoding.

1 Like

Hi, Already tried enabling Vulkan…

Compositor : Ok, interesting!
How do you disable xfce compositor and enable compton ?
Thx for your help fellows by the way!

I use picom. Installed it from the repos. Went in under startup settings and added picom %u