PHP issue with New installation apache-php-mysql

Mod-edit: formatting and clean up duplicate text.


Good evening,
The problems arrived with the new version of php the lines.
When PHP was in version 7.1, I had created a kind of xampp on my Manjaro by installing and configuring httpd, sqld and php.ini.
At that time, I had to uncomment:

# LoadModule unique_id_module modules/mod_unique_id.so

Then restart apache.

The problems arrived with the new version of php the lines:

#LoadModule mpm_event_module modules/mod_mpm_event.so

and

LoadModule mpm_prefork_module modules/mod_mpm_prefork.so

remain commented for the first one and uncommented for the second one.

But it seems that apache no longer supports the addition of these three lines in its configuration :

LoadModule php7_module modules/libphp7.so
AddHandler php7-script php
Include conf/extra/php7_module.conf

Indeed, when I launch an index.php page for example, apache returns errors: these three lines are no longer supported in httpd.conf .

I went on the apache website, but they only talk about php 8 and nothing about the new configuration of httpd.conf.

Did you have problems, if yes, how did you solve them?

Thanks a lot.

Provide the exact error lines, so people who want to help will be able to help.
Just mentioning you get errors without exact info and asking how others solved it is going nowhere.

I assume you have followed this guide right?

1 Like

Thank you for your response.

Of course I followed this tutorial.
Everything goes well until the installation of PHP and the modifications made to httpd :
Comment out :

#LoadModule mpm_event_module modules/mod_mpm_event.so

But I’ve found, it was a problem of .socket :grin:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.