Permanently enable mono audio output

Hey y’all, I’m trying out Manjaro again but the thing that has been holding me back most is the fact I can’t have Mono audio output, since I’m deaf in one ear
I can indeed use the PulseAudio channel using a command but it resets after each reboot, is there a permanent way of changing it?
Thanks in advance!

pipewire should be a good solution for your needs. while i’m not that experiencened in configuration of it i can only point at it. sorry that i can’t offer more help, you need to check the internet for examples,installation etc. maybe this two links are giving a first impression.

I would experiment with configuring pulse-audio.

copy /etc/pulse/daemon.conf to ~/.config/pulse/daemon.conf and edit it

man pulse-daemon.conf : these settings may have the desired effect

default-sample-channels The default number of channels.

default-channel-map The default channel map.

1 Like

Find the name of the output sink for headphones/speakers

pactl list short sinks

For an onboard audio device, the name will look similar to this:


Use this command to create the additional configuration for PulseAudio in user folder
using the correct name for the (master=) output sink
and set the remap module to be the default sink for audio playback

cat <<EOT > ~/.config/pulse/
.include /etc/pulse/
load-module module-remap-sink master=alsa_output.pci-0000_04_06.0.analog-stereo sink_name=mono sink_properties="device.description='Mono'" channels=2 channel_map=mono,mono
set-default-sink mono

Restart PulseAudio to load the additional configuration

systemctl --user restart pulseaudio

[ Archwiki - Pulseaudio Examples - Remap stereo to mono ]

There is no need to copy this file to home folder: All options in /etc/pulse/daemon.conf are inactive

Default values are commented out. Use either ; or # for commenting.

Changing default-channel-map might work ok instead of using the remap module, but I am not sure if it will work with the equalizer

Default setting default-sample-channels = 2 does not need changing

I suggest try this command to change default channel map

tee ~/.config/pulse/daemon.conf <<< 'default-channel-map = mono,mono'

Use this command to check daemon.conf configuration

pulseaudio --dump-conf

Thank you so much! I haven’t restarted my computer yet (there’s actually a problem with shutting it off too but oh well)
Anyways you’re the best :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.